Welcome! Log In Create A New Profile

Advanced

(Solved!) hp sound-hda-intel; No sound problem

Posted by voxorb 
(Solved!) hp sound-hda-intel; No sound problem
May 22, 2008 06:22AM
Quote

Original Text:

I have an HP tx1119us (tx1000) laptop. I've managed to get everything but the wireless card (not a priority at the moment) and the sound to work.

dmesg output:
htt://files.voxorb.net/dmesgout.txt

The issue:
Elive things it can play and has all the symptoms of playing. Mixer works and the visual aids show frequency output from elive. But the laptop thinks it's muted (the light on the onboard mute button is red).

Part way through boot (livecd or installed) it goes from blue to red and I'm unable to figure out why.

Any help or suggestions would be welcomed. Elive works with everything else I have (even my printer) and could easily become my favorite Linux distribution.

Upgraded my alsa to 1.0.16. For those of you who have similar issues you may need to do the same. FYI - Install GCC-3.4.0 before compiling the alsa-driver, alsa-util, alsa-tools and alsa-firmware source codes.



Edited 5 time(s). Last edit at 03/15/2011 05:21AM by anu.
adw
Re: [resolved] hp snd-hda-intel
October 15, 2008 04:42PM
Thanks voxorb, your problem (and solution should help a lot of people with this very popular laptop sound chip/driver.
Problem Sound Card
December 09, 2009 03:12PM
Hi!

I've working with elive - gem since about a year ago with any problem at all, but suddenly one day I turn on my pc and my usb devices were either found or detected and the same problem I come across with my sound card. I really dont know what could happened.

If I boot from CD every thing work properly, but if I boot from my HD I lost my sound card. this is what I've done until now:

when I type lspci I got this:
00:00.0 Host bridge: Intel Corporation 82845G/GL[Brookdale-G]/GE/PE DRAM Controller/Host-Hub Interface (rev 01)
00:02.0 VGA compatible controller: Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device (rev 01)
00:1d.0 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 81)
00:1f.0 ISA bridge: Intel Corporation 82801DB/DBL (ICH4/ICH4-L) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801DB (ICH4) IDE Controller (rev 01)
00:1f.3 SMBus: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) SMBus Controller (rev 01)
00:1f.5 Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 01)
01:08.0 Communication controller: Cirrus Logic MD 5620 [CLM Data Fax Voice]
01:0c.0 Ethernet controller: Intel Corporation 82540EM Gigabit Ethernet Controller (rev 02)

I assume the system detect both sound card and usb controlers but if I do this:

nrikex@Elive[/etc/init.d]$ sudo ./alsa reload
Unloading ALSA sound driver modules: (none loaded).
Loading ALSA sound driver modules: (none to reload).

if I type:

nrikex@Elive[/etc/init.d]$ sudo alsaconf

I got "No legacy drivers are available"

I don't know what else I can do, any Idea? thks in advance

P.S.
I really dont want reinstall my dist ... that would be so Windows
Re: Problem Sound Card
December 10, 2009 03:33PM
Ok, I already solve my problem about sound card, I google it and I found AlsaUpgrade-1.0.x-rev-1.X.sh script
I download it and run as root, after that I run again alsaconf and every thing work fine.

I still have the USB issue, I figure out the problem is because some how I lost the vfat support
Re: Problem Sound Card
December 11, 2009 09:23AM
AlsaUpgrade script does the trick, everything is working now, I don't know how but ever since I run the script the whole thing works. Its done

I hope this information could be usefull for some one else!
Sorry, only registered users may post in this forum.

Click here to login