Welcome! Log In Create A New Profile

Advanced

(Solved!) No Internet / Ethernet card

Posted by rashwan 
(Solved!) No Internet / Ethernet card
August 06, 2008 06:52AM
hello,
i have D-Link DWL-G510 that uses RT61 chipset dont seemed to be defined on GEN
when i lunch network properties from control center it freezes
any suggestion ?



Edited 3 time(s). Last edit at 02/23/2010 07:02AM by anu.
Re: No Internet
August 14, 2008 07:21PM
dont launch it from control panel. Log in to e16, then from the menu, select config->modem connection. There you go, configure it and happy hunting the net.
No internet
May 28, 2008 11:32AM
I can't get my internet connection working, i've been in the Elive panel and then network configurations. I've set the right properties but i can't activet netiher Wireless or Ethernet. Elive is installed on my Lenovo 3000 N200 laptop, anybody able to help me out, otherwise it seems like Elive runs smooth.
Re: No internet
May 29, 2008 11:26AM
Quote

Network/Wireless: Intel Wireless 4965AGN, Broadcom 10/100 Ethernet Card

The wireless can be a bit of a pain to set up. Try running the iw commands for setting it up (don't use the provided network configuration utility; it never properly setup my devices).

If you run "ifconfig", do you see wlan0 or eth0 listed? (the numbers could be different). If you don't then try running "ifconfig wlan0 up" and/or "ifconfig eth0 up" and see if they show up and we can go on from there.


[edit] You need to run the commands as root. Open up a terminal and type "su". Enter the root password and then commence.

The obligatory quotation notice...run the previously stated commands without the beginning and ending quotes.



Edited 1 time(s). Last edit at 05/29/2008 11:28AM by voxorb.
Re: No internet
June 09, 2008 01:03AM
If what voxorb said doesn't work try "dhclient" (without quotes) from the command-line as root.
ath0 up, but haven´t internet ...
October 03, 2008 03:55AM
i have wep security on my net and i have configurate with my wep key and dhcp client to dynamic ip, but no ip is assigned.
What is the problem?
Is a Macbook with Intel.
Thanks.

Macbook Pro user &
Mandriva Linux user
Need to config. internet at every start
October 25, 2008 06:14AM
Network connector has been improving for me over the last update. The profile name field which, had to be filled in with every start now is auto filled, but will not auto start at log in. Have to start network through the elpanel every time.
Some are spoiled by automatic internet at start after one time config.
no internet, no sound...
October 19, 2008 11:34AM
Quote

I got Internet on startup by adding 2 lines to
/etc/network/interfaces :

auto eth0
iface eth0 inet dhcp

However I got more problems with sound instead emosmile
CD Player/Rip-per doesn't work from menu. At the beginning CD played after just inserting a CD. After trying Skype (doesnt' work: "problem with sound capture) CD doesn't play anymore. Mixer gadget disappered from desktop and cannot be return (message: ...it's very bad..).
Please help to setup sound!



Edited 2 time(s). Last edit at 02/21/2010 03:43PM by anu.
!!My ethernet card works only with livecd!!
March 03, 2008 12:56AM
My ethernet card works only with livecd...when i installed in hdd,my router's led for ethernet light off...what can i do??Is it normal??@#@@!By the way..fantastic distro...good work boys...keep on clap



Edited 1 time(s). Last edit at 03/03/2008 01:20AM by username.
Re: !!My ethernet card works only with livecd!!
March 07, 2008 05:23AM
I'm sure you tried all the usual stuff right?
sudo ifconfig -a

to see what devices are actually detected by elive.

then assuming yours is "eth0" you do a
sudo ifconfig eth0 up


dhclient

If you've done this to no avail. try
lspci and look for your ethernet card to be sure it is in fact still there and being detected.

Try all that and post back..

emosmile
Ethernet card no work
November 23, 2007 10:07AM
hello i have an ethernet connection, but elive don't look my ethernet connection, how i can install my ethernet card please on elive???
Re: Ethernet card no work
November 24, 2007 01:46AM
please help why my ethernet card are not on the elive network panel??
mother carte : gigabytes GA-945GZM-S2
ethernet car integrated : Realteck RTL8169/8110 Family PCI Gigabit Etehernet (ndis 6.0)

please help!
how fix this probleme??



Edited 1 time(s). Last edit at 11/24/2007 02:16AM by mika2008.
Re: Ethernet card no work
November 24, 2007 02:55AM
well i make this :

00:00.0 Host bridge: Intel Corporation 945G/GZ/P/PL Express Memory Controller Hub (rev 02)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 01)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01)
00:1f.2 IDE interface: Intel Corporation 82801GB/GR/GH (ICH7 Family) Serial ATA Storage Controller IDE (rev 01)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 01)
01:00.0 VGA compatible controller: nVidia Corporation Unknown device 0402 (rev a1)
02:05.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8169SC Gigabit Ethernet (rev 10)


iwconfig
lo no wireless extensions.
sit0 no wireless extensions.
Re: Ethernet card no work
April 03, 2009 01:05AM
This solved it for me:

goto the following site:

"[www.opendrivers.com];

and download:

Free Download Realtek RTL8169 Driver 6.009.00 Linux Kernel 2.6.x & 2.4.x

from the "Backup Download Server"

r8169-6.009.00.tar.bz2

TRansfer this file via a flash drive to your Elive system and bunzip and follow the below steps:

To extract, do this : $ bzip2 -cd r8169-6.009.00.tar.bz2 | tar xvf -

cd top the extracted directory and:


mkdir /lib/modules/2.6.18-elive/build

make clean modules

make install

depmod -a

insmod /lib/modules/2.6.18-elive/kernel/drivers/net/r8169.ko

check if the driver is installed by using the following commands:

lsmod | grep r8169

ifconfig -a

Reboot you PC, and configure your network settings
after reboot, confirm that the driver is loaded by doing the following:

lsmod | grep r8169

If not, then some of the above steps did not complete successfully



Edited 3 time(s). Last edit at 04/03/2009 06:07AM by wicus.
Re: Ethernet card no work
April 03, 2009 01:09AM
If it does not load after a reboot, manually load it with this command as root:


insmod /lib/modules/2.6.18-elive/kernel/drivers/net/r8169.ko
.

test again now with
.

lsmod | grep r8169

.
If it was not loaded by default on a reboot, add it manually to the below file

/etc/modules

r8169



Edited 3 time(s). Last edit at 04/03/2009 06:08AM by wicus.
Internet
September 15, 2007 05:41PM
I have downloaded a variety of OS's, and usually the internet works automatically without any configuration. So can anyone tell me how to set up internet on Elive. I would be so extremely thankful.
Re: Internet
September 17, 2007 05:42AM
Have the same problem as dezaun. Don't require any configuration in other distros but in Elive I can't connect to the internet. help plz :(
rah
Re: Internet
September 17, 2007 06:27AM
I think, once installed, elive doesn't start your NIC.

The file /etc/network/interfaces is:

iface lo inet loopback
auto lo


You have to add this two lines to this file

auto eth0
iface eth0 inet dhcp

don't forget you must be root to edit this file.

I hope it helps
Re: Internet
September 18, 2007 08:09AM
Thank you for the help but it didn't work for me. The problem is I can't activate my eth0 or eth1 using dhcp. I don't have a static ip so don't know what to do next.. I can activate them if I type in my IP from Windows, but not connect to the internet.



Edited 1 time(s). Last edit at 09/18/2007 08:10AM by danser.
Re: Internet
September 18, 2007 11:04AM
Have you people tried elpanel. There is a tool that is used to configure network. If I remember correctly it is under administrator section.
rah
Re: Internet
September 19, 2007 09:18AM
I loosing the point.

If your need a static ip just type something like:
auto eth1
iface eth1 inet static
	address 10.0.1.52
	netmask 255.255.255.0
	network 10.0.1.0
	broadcast 10.0.1.255
	gateway 10.0.1.4

the gateway is for your router.

Next in /etc/resolv.conf write down your quickest DNS servers ip addresses like that:

nameserver 212.230.255.1
nameserver 212.230.255.129
rah
Re: Internet
September 19, 2007 09:21AM
Also you can request for an ip with
dhclient
Re: Internet
September 21, 2007 05:41AM
Well my internet should work with dhcp. Last night I managed to activate my eth0 and eth1 card with dhcp, but still no internet. I tried to use the settings from Dreamlinux which has the same network manager as Elive and in Dreamlinux my internet is working. But that didn't work in Elive. Can it be my network drivers that doesn't work?
Re: Internet
September 21, 2007 01:01PM
Hey again

I found out that my networkcard isn't supported in Elive.

[bugs.elivecd.org]

I have downloaded the drivers from Realteks website, but it fails when I try to install it.
The error looks like this.

-----------------------------------------

make: Entering an unknown directory

make: * * * /lib/modules/2.6.18-elive/build: no such file or directory. Stop

make: Leaving an unknown directory

make[1]: * * * [modules] Error 2

---------------------------------------

Anyone who knows what I do wrong?

ty for the help
Re: Internet
October 03, 2007 06:28AM
try going to elive panel,networks configuration,double click ethernet connection then click on activate.i hope this helps.
Re: Internet
November 06, 2007 12:47PM
I confirm that RLT8111 (Realtek) is not supported in Elive, I bought a new machine with a Gigabyte RLT8111 onboard network card. Elive would not recognize it at all, had to revert to Ubuntu 7.10, to bad :( Hope it gets fixed...
Re: Internet
November 23, 2007 08:14AM
I got my Elive back after installing a second ethernet card, that solved the internet problem. Having elive back justified opening the box. Anyway Ubuntu 7.10 (amd64) gave me big headaches (freezes, bugs,etc).
Re: Internet
May 04, 2008 02:20AM
Hi All,

it's not the same problem, but the question was already posted here.

In Germany, we have a Router producer: AVM (www.avm.de/en). The have really good stuff, but unfortunatally, not present outside germany.

They provide us a linux treiber of their Wireless USB Stick. But I've to compile it in order to make the driver.

I've the same problem as Danser, the source code are not present on the installed Elive and the make aborts the process.

How to get the source code of Elive ?

Regards,

Thirganor.
Re: Internet
May 28, 2008 05:42PM
Unfortunately after installing elive, I couldn't get internet access. I could use MSN, but not a browser or email. Unfortunately after trying a number of things I had to abandon and reinstall Linux Mint. No internet is a show stopper. Shame - I was looking forward to using it.
Can not activate wired rthernet card...
March 11, 2008 12:06AM
Hi everyone, first of all this distro is absolutely gorgeous!!
I did a full install and works fine,
only 2 things:
The Internet connection: I have a laptop with an Ethernet connection to a adsl modem, where normally I need to give username and password for the wer provider, and not only I can not find where to do it but also don't manage to activate my card I normally use it with DHCP :(

The next problem is to mount an external HD with NTFS and an usb stick (FTA32) it hallways gives some error message that in can not determine the mount point.
I tried right clic and mount but nothing :(
Can you guys help???

other than that everything seem to be fine, and I am loving this Enlightenment desktop!!!
regards
vasculho
Re: Can not activate wired rthernet card...
August 14, 2008 07:25PM
whoa, I had the same problem with internet. But i managed to fix it. First, log in to the e16 desktop.(its a bit more stable). Then from menus->config-> modem connection.
There elive will automaticall scan for your ethernet card and ask you to enter the username and password if it find any. Now, when a message is displayed asking to connect at boot up, click yes, for i still dont know how to activate it after i log in.(*the network connections in control panel wont work!). Now it will connect at boot up time provided you have switched on your modem!!!
kei
Re: Can not activate wired rthernet card...
September 03, 2008 08:30PM
realtek card have problems with elive, its a shame u_u i want to use elive but i can't acces the net
Re: Can not activate wired rthernet card...
August 19, 2010 11:46PM
Yo have to configure the setting first to function it well.

pavement marking
Sorry, only registered users may post in this forum.

Click here to login