Welcome! Log In Create A New Profile
We moved to this Improved Forum!

Do not use this old forum, we MOVED to here!


(SOLVED!) Shutdown problem

Posted by EricMGB1974 
This forum is currently read only. You can not log in or make any changes. This is a temporary situation.
(SOLVED!) Shutdown problem
March 05, 2010 02:20AM
This is more in the nature of an annoyance than a real problem, but once I installed elive 2.0 on my laptop it will no longer shut down. After clicking on the shutdown command the screen becomes garbled and then it hangs & won't complete the shutdown. I need to power off with the power button on the laptop. When I try to reboot the same garbled screen appears, but it does reboot. When shutting down from the log in screen the screen does not become garbled but it does still hang before finishing shutting down. This did not happen running from the live version on the USB stick. Any thoughts on what's happening & how to fix it? Thanks.

Edited 1 time(s). Last edit at 08/24/2011 09:26PM by anu.
Re: Shutdown problem(IBM X32 laptop)
March 08, 2010 05:16AM

I got the same problem on my ThinkPad 600x.
In the "unstabl" version (1.9.62) it worked fine.
Also during setup, rebooting worked fine.

The only things I changed were: installing Mousepad and Opera 10.10.
then I changed the mouse options in xorg.config to enable horizontal and vertical scrolling.
I diod the same in the unstable, so I don't think, I messed something up.

Any ideas how to shut down properly?

Re: Shutdown problem(IBM X32 laptop)
March 08, 2010 03:29PM

Today the screen didn't go black.
So, the shutdown continued until:
Disableing Laptop mode ok
Asking all processes to terminate and then it freezes.

Any ideas?

Re: Shutdown problem(IBM X32 laptop)
April 05, 2010 01:30AM
I have ELive on a ThinkPad SL400, and am, on the whole, quite pleased with the installation.

My only gripe, really, is as those comments above, that the system hangs, and the graphics screw up, when I reboot or shut down the system.

I can logout, back to the login screen without any issues. However, upon choosing either reboot or shutdown the systems hangs at about 75% of the way through the process.

These issues occur EVERY TIME, and I'd really rather that they didn't. It's a bit like having a really nice looking sports car, only to have it breakdown before your friends' eyes.

Not much to brag about!

A resolution would be most welcome. Sooner, rather than later. As I notice the first comment was made here on March 05 of 2010, and still no answer or comment has been forthcoming.

Thank you.
Re: Shutdown problem(IBM X32 laptop)
May 29, 2010 11:44PM
Same problem here.
I`m running elive 2.0 on ThinkPad T60 and facing the same problem described above.

Every time during shutdown process it hangs around 75% with the message "Asking all processes to terminate ..."

Is there some solution available?

Re: Shutdown problem(IBM X32 laptop)
May 30, 2010 06:22AM
I've just disabled the splash screen and now it works.
Unfortunately.... Now I'm missing the nice splash omfg
Re: Shutdown problem(IBM X32 laptop)
June 13, 2010 05:18PM
I've just finished installing Elive 2.0 (uname -r => on my ThinkpadZ61M and I too are suffering the same issue with garbled screen and a hang shutdown/reboot.

However, I noticed that if I disconnect wlan0 interface before initiating shutdown/reboot, the garbled screen still appears, but at least the shutdown/reboot completes.

I used "elive_2.0_Topaz_old-kernel_up001.iso" image when installing. I'll try upgrading to the newer version "elive_2.0_Topaz_new-kernel_up002.iso" before submitting a bug report.

I did search the forums before posting but as always, search results are always as good as the search phrase and although the solution may already be posted, I haven't found it yet but will keep searching.

Re: Shutdown problem(IBM X32 laptop)
June 15, 2010 01:06PM
Alright. I went ahead and did an upgrade to "elive_2.0_Topaz_new-kernel_up002.iso" and the problem persists. Not only that, but during the upgrade I was informed that not a single file would be affected! Well, my customized ~/.bashrc file was clobered, the /root/bin directory was obliterated; lucky for me it only had two scripts that were already backed up!

So, it looks like I need to collect more data before reporting a bug. In the meantime, please have a look at the screen corruption occurring when shutting down or rebooting:
Re: Shutdown problem(IBM X32 laptop)
June 16, 2010 04:20AM
same problem here with a x30
@chdrsto: how did you deactivate the splashscreen?
in the bootloader?
Re: Shutdown problem(IBM X32 laptop)
June 24, 2010 01:36AM
Could you please tell me how you disabled the splash screen? Thank you.
Re: Shutdown problem(IBM X32 laptop)
August 03, 2010 12:15AM
Dear all,

I have a similar problem on my Thinkpad R50e. Everything runs fine, but shutting down, suspending or hibernate doesn't work.

shut down: stops after some time (cannot see the log, so don't know where) and the machine continues to run
suspend: suspends, but when returning the systems has a kind of freeze. all opened windows remain and I am not able to close them.
hibernate: hiernates, but is not able to return, screen stays blank and the caps lock light starts blinking, nothing more happens.

Somebody any ideas?

Thanks a lot.

Re: Shutdown problem(IBM X32 laptop)
August 09, 2010 09:04AM
Now I believe I have elive_2.0_Topaz_new-kernel_up002.iso, but I never did have a splash screen, so I am not missing anything (but of course I can't set backgrounds on my VTs now) so hells yeah I miss the splash.

I was browsing forums and in other distros, right before X starts, they were advised to add a USPLASH STOP (I have the usplash in my /etc/init.d in LiveCD Topaz). If you have your older Elives somewhere, check out /etc/rc2.d and there is a stop bootsplash right before entrance kicks in. And no, it's not a Knn function; if you know your sysinit V (did I even get that correctly), you'd understand.

My guess too is that since bootsplash has gone the function is no longer there, but if you are clinging onto your older Elive...
Re: Shutdown problem(IBM X32 laptop)
November 27, 2010 07:47PM
EricMGB1974 Wrote:
> Could you please tell me how you disabled the
> splash screen? Thank you.

When you get to the boot menu, press "e" for edit mode and remove the "splash=silent" entry and press enter

If you want to remove it without doing this all time, than you have to edit the ...:

Thanks and Sorry for long waiting.


Edited 1 time(s). Last edit at 11/27/2010 07:47PM by chdrsto.
Re: Shutdown problem
February 15, 2011 10:11PM
I've got the same problem. No shutdown, no reboot. Is there nothing else but disabling the splash-screen?

Greez andreasp
Re: Shutdown problem
May 20, 2011 05:54AM
a system that does not shut down properly, a distro thats not free; I paid for, but no support; a forum with strict censorship. Thats in a way ridiculous, not appropriate and sad. What a cheek. We say: if I had the money thrown into the drain, I would have heard at least a plop emosmile
You will never be successfull with that way!

Bye bye elive
Re: Shutdown problem
June 22, 2011 11:46AM
Im giving this a bump because I too am having the same issue on a Lenovo R60. Seems to be a reoccurring issue with IBM laptops. ( had no issues out of it on my Dell D400 Latitude )
Did some looking around on the internet, but havent had any good luck yet finding anything that has worked. I'll keep this thread updated if i am successful in solving the issue.
Re: Shutdown problem(IBM X32 laptop)
June 23, 2011 12:57AM
usplash[31791]: segfault at bfed6004 ip b7e76717 sp bfed44a0 error 4 in libecore_fb-ver-pre-svn-05.so.0.9.9[b7e73000+5000]

in shutdown on Acer Aspire 5710 so disabling the splash as described does work but I expect a resolution!!!
Re: Shutdown problem(IBM X32 laptop)
June 23, 2011 03:08AM
Thanks for the quick response, I will try that tonight and hopefully it works! emosmile
Re: Shutdown problem(IBM X32 laptop)
June 23, 2011 01:38PM
I removed the splash screen and it worked like a champ! Thanks again for the speedy response.
Re: Shutdown problem(IBM X32 laptop)
July 03, 2011 10:52AM
Thanks for the info. I removed "splash=quiet" from the menu.lst
in the /boot/grub/menu.lst and it works like a charm on
Thinkpad T23