Welcome! Log In Create A New Profile
We moved to this Improved Forum!

Do not use this old forum, we MOVED to here!


(SOLVED!) GRUB /(duall) Boot failures

Posted by Jedidyah 
This forum is currently read only. You can not log in or make any changes. This is a temporary situation.
Boot processes
August 17, 2009 07:27PM
I've installed version 1.9.39 and was reconfiguring the processes to launch at boot. Installed rcconf for this. I disabled some services (like acpi as I have an old system which doesn't support this), but acpi still loads at boot.
This is what dmesg gives:
[    3.606559] thermal: Unknown symbol acpi_processor_set_thermal_limit
[   41.955740] powernow_k7: Unknown symbol acpi_processor_notify_smm
[   41.956047] powernow_k7: Unknown symbol acpi_processor_unregister_performance
[   41.956433] powernow_k7: Unknown symbol acpi_processor_register_performance
[   42.036355] acpi_cpufreq: Unknown symbol acpi_processor_notify_smm
[   42.036709] acpi_cpufreq: Unknown symbol acpi_processor_unregister_performance
[   42.037327] acpi_cpufreq: Unknown symbol acpi_processor_preregister_performance
[   42.037724] acpi_cpufreq: Unknown symbol acpi_processor_register_performance

I also blacklisted some kernel modules (like ipv6 and floppy) in both /etc/modules and /etc/modprobe.d/blacklist, but they are still loaded at boot. Is there another place where they should be blacklisted?

Edited 1 time(s). Last edit at 08/17/2009 07:28PM by Torllan.
Re: Boot processes
August 22, 2009 12:31AM
You can boot with the "noacpi" option (add it in /boot/grub/menu.lst).
boot issue
March 07, 2010 03:08AM
I have installed elive 2.0 about 10 times since yesterday using different file system offered by the distro. At boot I get the list of OS in my box in this case Debian Squeeze and Elive. When I chose Elive I get the following error:
root (hd0,1)
Filesytem type unknown, partition type 0x7
Error 17: Cannot mount the selected partition

My machine has two SATA hard drives:
500G Debian Squeeze
250G Elive Topaze

I can still boot into Debian via Elive Grub list but Elive is a no no.

Is there a known issue with Elive on SATA?

Re: boot issue
March 08, 2010 09:00PM
Changed (hd0,1) to (hd1,1) in menu.list per the Man wave instructions.
Topaz Suddenly Won't Boot
April 07, 2010 05:21AM
Suddenly, my Topaz installation won't finish booting. Is there a verbose boot mode that I can invoke to try and trouble shoot the installation? It gets to the splash screen, then about 3/4 of the way through "starting services". The last line in the background that I can read says something about "cupsd - ok", and then it hangs; but I can't read anything else. There is no printer connected to this machine at this time, nor have I tried to install a driver. ??? The system has run fine since February.

Any and all suggestions cheerfully and gratefully accepted.

Michael B. in Cincinnati
Re: Topaz Suddenly Won't Boot
April 07, 2010 06:38PM

That sounds really weird.
Okay so there is a verbose mode. Just press alt+F1 (or was it F2?) anyway. alt+F1 or F2 should activate verbose mode.
The really weird thing here is you are talking about Topaz and you are running it since February.
Elive Topaz was released in the first days of March!
So I really doubt you are running Topaz but a prerelease.
Try this in a Terminal:
cat /etc/elive-version

That will show you exactly what version you are running.

Have Fun!

Elive für Einsteiger: [sites.google.com]
Re: Topaz Suddenly Won't Boot
April 08, 2010 03:55AM
Alex: thanks for your kind reply! Alt-F1 does put the system into verbose mode, and two things come up:

1.) There are a number of references to "file system NOT clean".
2.) The line that the boot halts at is 38.7920009, and has to do with networking and tracing.

Given (1.) above, should I try running fsck from the live CD? or ??

Thanks again.

Michael B. in Cincinnati
Re: Topaz Suddenly Won't Boot
April 12, 2010 09:16PM
Hi Michael!
Have you tried booing to reparation-mode?
Chances are this can solve your problems.

PS: How about joining Elive's IRC #elive on irc.freenode.net!? There you can get help much quicker.


Elive für Einsteiger: [sites.google.com]
Re: Topaz Suddenly Won't Boot
April 15, 2010 03:53AM
Figured it out, motherboard was sick! I installed the hard drive into another machine, and all is well.

Thanks for your quick response!

Michael B. in Cincinnati
(SOLVED!) GRUB /(duall) Boot failures
May 24, 2010 01:54AM
edit: here you will find different solved and merged topics, releated to botting and grub

I have a Dell Inspiron 1545. I was dual booting with Vista/Mint 8 when a grub2 conflict nearly ate my BIOS. I was able to recover Vista by installing grub from Puppy, but Puppy doesn't see my wireless. I like the looks of this distro, but before I install it, wanted to know if it will run into conflict. I'd appreciate your input.

Edited 5 time(s). Last edit at 09/08/2011 06:25PM by anu.
boot failure
May 25, 2010 07:24AM
I burned the Elive 2.0 to dvd, chose the installer icon from the live cd, donated and downloaded the module. After installation and reboot, I see Error 15:File missing when it tries to boot Elive. I'm able to open Mint 8, but my WIndows Vista isn't in grub anymore.
Any suggestions?
Re: boot failure
May 26, 2010 04:35AM
There is a way to edit your /boot/grub/menu.lst to add windows. Google /boot/grub/menu.lst and windows and see what you get.
Re: boot failure
May 26, 2010 04:35AM
Victory! I reinstalled from the DVD, this time I first downloaded the .mod from email (and left it visible in download), then I connected to the WIRED internet, then everything seems to have gone smooth as silk! Looking forward to enjoying discovering this distro.emosmile
Re: boot failure
May 26, 2010 04:38AM
Thanks. it looks like the reloading fixed grub already.
GRUB not booting into the OS (Rescue Mode)
January 01, 2011 07:57AM
After five installations, this is getting to be a bit frustrating. I've never had this issue with any of the (many) other Linux OS that I've used.

I'm installing Elive Topaz 2.0 on an EeePC 901. There are two HD's, one is a 4 GB drive and the other is a 16 GB drive, both solid state. I've been installing the OS onto the 16 GB drive.

I've installed the OS to the 16 GB drive, which is /dev/sdb. During the installation, I am asked where to install GRUB, and I choose the recommended of installing Grub onto the MBR partition, where the OS resides. Upon reboot, Grub goes into rescue mode. It never boots into the OS. I've tried booting back into the LiveCD and then editing my /boot/grub/menu.ls file but have not had any success with being able to get Grub to boot into the OS. Anyone have any ideas? I'm at a loss here. Thank you!

/dev/sda1 = unused 4 GB drive
/dev/sdb1 = swap
/dev/sdb2 = root
Re: GRUB not booting into the OS (Rescue Mode)
January 01, 2011 04:14PM
After disabling the 4 GB drive in the bios (which made no difference), numerous installations and many attempts to edit /boot/grub/menu.lst, the thing that finally worked was to specify the automatic installer method (which supposedly asks the least amount of questions during the installation). It still asked me where to install Grub and I specified the same location, /dev/sdb. I'm not sure why it finally worked but I'm happy to say that it did. The many hours of time that I spent working on this today really made the purchase worth while! Regardless, the OS seems quite nice and is a bit different than other Debian systems that I use regularly.
Re: Grub
May 17, 2011 12:21PM
This was solved - elive works great on my Dell, no problem with wireless