Welcome! Log In Create A New Profile

Advanced

(Solved!) Keyboard/Language Layouts

Posted by Andrius 
(Solved!) Keyboard/Language Layouts
December 09, 2010 02:01AM
Hi folks, I know that's probably basic, but how do you add more than one keyboard layout and how do you switch between them without e17 self reboot???

I use Elive 2.0



Edited 2 time(s). Last edit at 08/25/2011 06:07AM by anu.
Re: Keyboard Layouts
December 12, 2010 04:57AM
I guess using the language module should do it.

Elive für Einsteiger: [sites.google.com]
Re: Keyboard Layouts
January 07, 2011 05:22AM
AlexAnteMachina Wrote:
-------------------------------------------------------
> I guess using the language module should do it.

Well, I have the same question, but that suggestion doesn't help, because I don't know what the "language module" is, or how to use it.

However, I have found an alternate solution, and I will describe it here.

setxkbmap is a tool to query and change the current XKB map. It is included in the package x11-xkb-utils, which is in the repository.

Once setxkbmap is installed, I can run the following command in the terminal:

setxkbmap -option grp:switch,grp:alt_shift_toggle,grp_led:scroll us,ca

That command sets the key combination Alt-Shift to toggle the key map between us and ca (I am from Québec).

But it would be inconvenient to have to run that command manually each time I want to switch between layouts. The solution is to create a .desktop file that includes that command. The .desktop file becomes an executable "application", that can then be placed with all the other .desktop files in the folder /usr/share/applications.

Here is the complete .desktop file, called "keyboard-fix-e17.desktop"

[Desktop Entry]
Name=Keyboard-fix-e17
GenericName=Keyboard-fix-e17
Comment=Fix hanging keys on loading e17 keyboard switcher
Encoding=UTF-8
Exec=setxkbmap -option grp:switch,grp:alt_shift_toggle,grp_led:scroll us,ca
Icon=
Terminal=false
Type=Application
Categories=
StartupNotify=false

After placing the .desktop file in the /usr/share/applications folder, the next step is to add the file to the commands that are run automatically when eLive starts up. Do that by going to the Apps tab of the Settings panel, select Startup Applications, find keyboard-fix-e17 in the list on the left, and add it to the list on the right.

I hope that helps, Andrius and others with the same problem.

If you know an easier way using the Language module, please describe it in detail for us newbies!
Re: Keyboard Layouts
August 20, 2011 08:17AM
Hello,
How to configure the keyboard us intl for aspire 3000?
thanks
Keyboard configuration for us_intl
August 20, 2011 10:12AM
Hello,
How to configurate the keyboard us_intl for aspire 3000?
thanks
anu
Re: Keyboard configuration for us_intl
August 25, 2011 03:08AM
Section "InputDevice"

    Identifier     "Generic Keyboard"
    Driver         "kbd"
    Option         "CoreKeyboard"
    Option         "XkbRules" "xorg"
    Option         "XkbModel" "pc104"
    Option         "XkbLayout" "us,lt"
    Option         "XKbOptions" "grp:alt_shift_toggle"
EndSection

US - Lithuanian language layouts,
setup at /etc/X11/xorg.conf, alt+shift to change
ofc you have to have needet language pack & for that use synaptic or apt
changing keyboard from US to UK setting?"
January 14, 2010 03:48AM
I am sure there must be a simple way to do this but my keyboard seems to be stuck in US format for typing, My location and time is fine, (United Kingdom)


HP Compaq 6720s triple boot, Elive Zeitgeist/Fedora/Vista
Re: changing keyboard from US to UK setting?"
January 16, 2010 11:46AM
Hi,
Did you had a look to Main Menu => Configuration => Config Panel => Language => Keyboard feature?
If this menu is not present you have to enable the module going Main Menu => Configuration => Modules and enable (put from left column to the right one) module named "Languages"

*I'm not sure about exact translations as my desktop is in french...

Hope it helps...
Ciao

MerMouY

Some of my websites:
Communautary website idea: [teams.elivecd.org]
Personnal website: [perso.youm.org]
Rwanda, french community: [rwandaises.fr]
YouM's streeshow: [youm.org]
Re: changing keyboard from US to UK setting?"
January 17, 2010 03:34AM
Yes, he module did need adding, thanks! after a reboot I can access the keyboard language chooser from the "Other" settings menu


I am still having a problem after each reboot, it doesn't remember the settings.



Edited 1 time(s). Last edit at 01/17/2010 05:09PM by michaeljking.
Re: changing keyboard from US to UK setting?"
January 18, 2010 02:04AM
Hi!
wave

You should boot into nurse-mode. There you'll find a "Keyboard" option which should solve your problem.

Have Fun!

Elive für Einsteiger: [sites.google.com]
Language change shortcut change problems =/
February 13, 2010 07:15AM
Hello,

I tried to change language with the shortcut I'm used to, Shift+Alt. But I found those problems:

1.) When I try to add the shortcut Shift+Alt the system ignores it
2.) When I've set "next language" to alt+shift+1 and "prev lang" to alt+shift+2, both shortcuts change it to 2nd lang and it doesn't loop anymore
3.) So I have to click on the icon in the gadget(placed in shelf9) to change back to 1st language


Any solution? Please?
P.S.: Latest dev, no compiz wink



Edited 1 time(s). Last edit at 02/13/2010 07:17AM by Dany0.
Re: Language change shortcut change problems =/
March 10, 2010 03:56PM
It can be that in xorg.conf exist another shortcut to change layout. Remove it and restart Xserver.
And usualy it's enough 1 shortcut to circle betwin Lang.



Asus EeePC 1000H [Elive 2.0 Topaz]
Toshiba Satellite p10-802 -ATI video, ATI chipset, RealTech audio- [Elive 2.0 Topaz]
I hate ATI... but I love Elive. It work with ATI with no problem.
keyboard layout
September 01, 2009 07:00AM
I have a problem,
I used the cedilla with the combination '+ c, but now instead of cedilla return c with the ' accent

my xorg.conf
Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us_intl"
EndSection
Re: changing keyboard from US to UK setting?"
December 09, 2011 04:17AM
Mermouy Wrote:
-------------------------------------------------------
> Hi,
> Did you had a look to Main Menu => Configuration
> => Config Panel => Language => Keyboard feature?
> If this menu is not present you have to enable the
> module going Main Menu => Configuration => Modules
> and enable (put from left column to the right one)
> module named "Languages"
>
> *I'm not sure about exact translations as my
> desktop is in french...
>
> Hope it helps...
> Ciao


Hi,
Downloaded and installed latest version ,but there is no "Configuration" in the main menu !
Help please ?:(
Re: changing keyboard from US to UK setting?"
July 13, 2016 01:52AM
AlexAnteMachina Wrote:
-------------------------------------------------------
> Hi!
> wave
> [deadliftdonkey.com]
> You should boot into nurse-mode. There you'll find
> a "Keyboard" option which should solve your
> problem.
>
> Have Fun!

How do you boot into nurse mode?



Edited 2 time(s). Last edit at 12/31/2016 08:14AM by Lava.
Sorry, only registered users may post in this forum.

Click here to login