Welcome! Log In Create A New Profile

Advanced

(Solved!) NVidia could not open the device after Systemcrash

Posted by bohnor 
(Solved!) NVidia could not open the device after Systemcrash
March 13, 2011 08:13AM
I´m using Elive 2.0 new kernel.

At copying Mediafiles to my USB-Stick comes an Enlightenment Error with Systemcrash and now i can´t Start Elive again.
Elive booting is normal, but after the Login, started the Loginscreen again and what ever i make (Default, Enlightment Failsafe) i have only the Login Screen.

Password is correct and Keyboardlayout too.

If i want start Elive Nurse, i have following Error-Messages:

NVidia could not open the device file /dev/nvidia0 (input/output error)

(EE) Nvidia0: Failed to initialize the NVidia graphics device PCI:1:0:0.
(EE) NVidia0: Please check your system's kernel Log for additional error
(EE) NVidia0: Message and refer to Chapter 8: Common problems in the
Readme for additional information
(EE) NVidia0: Failed to initialize the NVidia graphics device!
(EE) Screen(s) found, but non have a usable configuration

Fatal server error:
No screens found

Waiting for xserver to begin accepting connection
Giving up
xinit: Connection reset by peer (errno 104)
xinit: No such process (errno 3): server error


And so is it unable to use the Nurse-mode. Rebuild of xorg.conf make no result.
My Graphic card is the Palit GTX 240 with 512mb ram. Installed NVidia Graphic-driverversion is 185.18.36-2

Please, help me i don´t know enough about linux.
Regards Norbert



Edited 4 time(s). Last edit at 08/25/2011 04:03AM by anu.
Re: hot smileyCan't start Elive after Systemcrash
March 16, 2011 07:10AM
Did you get good graphics in LiveCD mode? It makes a best guess to adapt to your card. I would only select the other older drivers in case something isn't working. Once you have selected a good one in live mode, you should pick the same in installed mode. I wouldn't put another driver in its place, by myself, not even from nvidia as that is a sure road to trouble for a n00b.

Try a different live distro to see if it has problems with the graphics card.
Can't start Elive after Systemcrash
March 16, 2011 11:24AM
The problem is solved,

I´ve been googelt for this error:

Fatal server error:
No screens found

Waiting for xserver to begin accepting connection
Giving up
xinit: Connection reset by peer (errno 104)
xinit: No such process (errno 3): server error


And saw, this must be a network problem.
An installed program blocked the connection to the xserver, this program rans with "autostart". I have been changed the autostart entry from "yes" to "no". That´s why i didn´t came in the nurse mode, now it´s OK.

I´ve been reset the configuration for my user in the repair mode, but i can´t login for the user. After the login comes shortly a blackscreen, then i have the loginsreen again.

I´ve created a new user and now it´s OK too.

The enlightenment error in use of the usb-stick, is maybe a conflict with the themes i have installed. I´ve tested the Stick in the original Elive configuration and have no problems.

I know my english is bad, but i hope you understand me.

regards bohnor
Re: Can't start Elive after Systemcrash
March 22, 2011 06:50PM
Oh I've had that problem too, when I saved my older .e and its subfolders, X server would crap out and refuse to start. So I started with a fresh .e and added old themes one by one to see which ones were updated enough not to crash X+e17. But I am glad you were able to fix the problem you had.
Sorry, only registered users may post in this forum.

Click here to login