Welcome! Log In Create A New Profile
We moved to this Improved Forum!







Do not use this old forum, we MOVED to here!

Advanced

SD-card support

Posted by az_s_za 
This forum is currently read only. You can not log in or make any changes. This is a temporary situation.
SD-card support
December 19, 2007 03:37PM
Nothing happens when I insert an SD-card. I have tried this on Elive Gem, as well as the latest development verion (1.2.24).

How do I mount an SD-card?

How do I configure my system to auto-mount them in the future?
Re: SD-card support
December 20, 2007 06:05PM
Also, is it just me with this problem?

Do SD-cards work out-of-the-box for the rest of you?

Please HELP!
Re: SD-card support
December 21, 2007 07:50AM
Is this a built-in SD reader for a laptop?

Some of the Texas instrument card readers work...

[ubuntuforums.org]
Re: SD-card support
December 21, 2007 07:54AM
Weird, it seems like the link I tried to post didn't take, well google for " HOWTO: Make your TI internal card reader work for you" and ubuntu and you should get the howto and some helpful links as well.

perhaps the powers that be could compile in the tifm modules for the next release? Maybe even next beta? 1.2.5?
Re: SD-card support
December 22, 2007 07:56PM
Thanks, you've helped me a lot. I am now half way there.

Yes, it is an internal SD-card reader.
I have been googling for awhile trying to find an answer, but your google terms worked better.

I found that there are 3 modules that need to be loaded at boot for this to work:
tifm_7xx1, tifm_core and tifm_sd


With the command
lsmod
(lists loaded kernel modules) I was able to see that only two of the three were loaded.

I got the third one with this command:
modprobe tifm_sd

To make them all load on startup, I added all three to my /etc/modules file.
After doing this, I find that when I insert an SD card, it shows up in /dev/disk/by-label/"SD-card name"

so I had to mount it as root by:
# mkdir /mnt/SD
# mount /dev/disk/by-label/SD /mnt/SD
(my SD-card was called "SD")

So, now I can use the SD-card, but I have to mount it from the command line anytime I want to use it.

How do I get it to auto-mount when inserted?
Re: SD-card support
December 27, 2007 05:00AM
Thanks for voluminous reply.

I am sorry that I can't be more helpful, but you should google and/or search this forum for 'ivman'.
Re: SD-card support
December 27, 2007 10:20AM
Quote

you should google and/or search this forum for 'ivman'.
thanks.

A quick google and it looks like ivman IS what I need. However, I haven't found a simple enough how-to yet. I'll try again when I have more time to play with it and post my results here.

Cheers.
Re: SD-card support
December 29, 2007 09:47PM
I don't have the know-how to edit ivman, or the time to work out how. So, I've just made two simple scripts which I've called "SD-card_IN" and "SD-card_OUT" to mount and unmount them for me, then added them as application launchers to my ibar.

That'll do until the process is (hopefully) incorporated into Elive.