Welcome! Log In Create A New Profile

Advanced

wireless woes: ifconfig gives segmentation fault, using rt61 driver

Posted by thinpaperwings 
wireless woes: ifconfig gives segmentation fault, using rt61 driver
December 31, 2007 04:06PM
I'm using a RaLink chipset that uses an rt61 driver:

# lspci | grep Ra
04:09.0 Network controller: RaLink RT2561/RT61
802.11g PCI

The kernel module for the driver appears to be properly installed:

# lsmod | grep rt61
rt61 221064 0

# modinfo rt61
filename: /lib/modules/2.6.18-elive/extra/rt61.ko
author: [rt2x00.serialmonkey.com]
description: Ralink RT61 802.11abg WLAN Driver
1.1.0 BETA1 2006/06/18
license: GPL
vermagic: 2.6.18-elive SMP preempt mod_unload
386 REGPARM gcc-3.4
depends:
alias: pci:v00001814d00000301sv*sd*bc*sc*i*
alias: pci:v00001814d00000302sv*sd*bc*sc*i*
alias: pci:v00001814d00000401sv*sd*bc*sc*i*
parm: ifname:Network device name (default ra%d) (charp)
parm: debug:Enable level: accepted values: 1 to
switch debug on, 0 to switch debug off. (int)

Yet I can't get wireless internet connection to work:

# iwconfig
ra0 RT61 Wireless ESSID:""
Mode:Managed Frequency:2.412 GHz Bit Rate=1 Mb/s
RTS thr:off Fragment thr:off
Encryption key:off
Link Quality:0 Signal level:0 Noise level:113
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

I've tried manually configuring the /etc/network/interfaces file as follows, but that hasn't seemed to help anything:

iface lo inet loopback
auto lo

auto eth0
iface eth0 inet dhcp

auto ra0
iface ra0 inet static
address 192.168.1.115
network 192.168.1.1
netmask 255.255.255.0
wireless-essid [MyESSID]
wireless-key [MyWEPkey]
wireless-channel 6
wireless-mode managed

Whenever I try to ifup ra0 or activate the wireless via the gui in the control panel, the system hangs and I have to reboot.

When I type
ifconfig ra0 up
I get a segmentation fault.

I've spent weeks thinking about this, checking tutorials and how-tos, and reading forum threads, but don't understand what the problem is and how to fix it.

Let me know if it is helpful to know any other stats about my computer or wireless setup.

I greatly appreciate any help.
Re: wireless woes: ifconfig gives segmentation fault, using rt61 driver
January 01, 2008 12:41PM
I should add that I was able to get the wireless connection working in debian, so it would seem that I should be able to get it working with elive. There was something I did to make it work, but I don't remember what it was. I remember it being trivial, though.
Re: wireless woes: ifconfig gives segmentation fault, using rt61 driver
January 01, 2008 03:07PM
Another additional tidbit of information: since I have the original chipset and not rev B, I have uninstalled network-manager and network-manager-gnome, as per the instructions here:
[help.ubuntu.com]



Edited 1 time(s). Last edit at 01/01/2008 03:12PM by thinpaperwings.
Re: wireless woes: ifconfig gives segmentation fault, using rt61 driver
January 13, 2008 12:56AM
Is no one responding because
(1) I've overwhelmed the reader with too much information,
(2) no one feels qualified to help,
(3) there is no one knowledgeable (with enough time to spend) on this forum,
or
(4) I'm such a n00b that I'm not worth helping?
Re: wireless woes: ifconfig gives segmentation fault, using rt61 driver
January 20, 2008 03:59PM
I'm sorry for the delay... and i will notif someone... i am not good at wifi stuff at all, so i can not help you.
Re: wireless woes: ifconfig gives segmentation fault, using rt61 driver
February 17, 2008 05:26AM
I've got the exact same problem with Elive Gem witch coulf be a very sexy distribution if wwireless works !!!

Worst, it works with a 1.5 unstable !!!! but not in the payware one.

I'm a bit furious.

And I cant find any way to upgrade (no network on my old laptop) or get the cdrom correctly mounted in synaptic.

GRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRR
D.
Sorry, only registered users may post in this forum.

Click here to login