Welcome! Log In Create A New Profile
We moved to this Improved Forum!







Do not use this old forum, we MOVED to here!

Advanced

(Solved) Sound Problem with Intel Chipset and Kernel > 2.6.26

Posted by lumussolem88 
This forum is currently read only. You can not log in or make any changes. This is a temporary situation.
(Solved) Sound Problem with Intel Chipset and Kernel > 2.6.26
December 16, 2011 08:10AM
Ok, in topic "Installer-module Features: Trial Install" I commented my sound problem initially.
My computer have sound problem with the newer kernel.
The sound problem is that with GStreamer is "accelerated" and with Xine is faltered.
This happens with all distros with a kernel greater than 2.6.26.

Some information about my PC:

/proc/cpuinfo/
processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 8
model name : Pentium III (Coppermine)
stepping : 6
cpu MHz : 863.871
cache size : 256 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 2
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 sep mtrr pge mca cmov pat pse36 mmx fxsr sse up
bogomips : 1729.07
clflush size : 32
power management:

lspci
00:00.0 Host bridge: Intel Corporation 82815 815 Chipset Host Bridge and Memory Controller Hub (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 82815 Chipset Graphics Controller (CGC) (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 02)
00:1f.0 ISA bridge: Intel Corporation 82801BA ISA Bridge (LPC) (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801BA IDE U100 Controller (rev 02)
00:1f.2 USB Controller: Intel Corporation 82801BA/BAM USB Controller #1 (rev 02)
00:1f.3 SMBus: Intel Corporation 82801BA/BAM SMBus Controller (rev 02)
00:1f.4 USB Controller: Intel Corporation 82801BA/BAM USB Controller #1 (rev 02)
00:1f.5 Multimedia audio controller: Intel Corporation 82801BA/BAM AC'97 Audio Controller (rev 02)
01:0c.0 Ethernet controller: 3Com Corporation 3c905C-TX/TX-M [Tornado] (rev 78)

And now, I finally found a fix for this!

Running a multi-boot desktop with the following sound hardware:
Multimedia audio controller:
Intel Corporation 82801BA/BAM AC'97 Audio Controller (rev 02)
Subsystem: IBM Netvista A40/A40p
Flags: bus master, medium devsel, latency 0, IRQ 17
I/O ports at f000
I/O ports at f400
Kernel driver in use: Intel ICH
Kernel modules: snd-intel8x0

Booting F9 (kernel-2.6.27.5-41.fc9.i686) shows these (good) messages in
dmesg, and then sound plays back at a correct-sounding speed and pitch:
intel8x0_measure_ac97_clock: measured 50775 usecs
intel8x0: clocking to 41134

Booting newly-installed F10 (kernel-2.6.27.5-117.fc10.i686) shows these
(bad) messages in dmesg, and then sound plays back too fast and too tinny:
intel8x0_measure_ac97_clock: measured 50917 usecs
intel8x0: measured clock 78 rejected
intel8x0: clocking to 48000

The problem has been circumvented in F10 by adding the following statement to
/etc/modprobe.d/modprobe.conf.dist:
options snd-intel8x0 ac97_clock=41194
(Using 41194 instead of 41134, as per various recommendations in internet.)


I just want to share this, and if it's possible, help to fix it!

Thanks a lot.


Source: RedHat Bugzilla



Edited 1 time(s). Last edit at 12/18/2011 11:08AM by lumussolem88.