Welcome! Log In Create A New Profile
We moved to this Improved Forum!

Do not use this old forum, we MOVED to here!


Kernel panic stopps booting after "fine tuning"

Posted by benfm 
This forum is currently read only. You can not log in or make any changes. This is a temporary situation.
Kernel panic stopps booting after "fine tuning"
January 17, 2009 07:31AM
Hi there,
i tried the unstable macbookversion of elive today.
(1.9.21) in live-mode it worked very fine. but after installing it to harddisk, and starting the "fine-tuning" a kernel-panic leaded to a stop of the boot-progress very early after reboot...

Details: After installing to hd, the first boot worked pretty well. But then i started a progress wich intended to "fine-tune" my macbook-elive. I changed nothing else.
My machine: Macbook (4.1)

These were the last entrys of the showed log:

"RAMDISK: Couldn´t find valid RAM disk image starting at 0.
Replacing swsusp
TuxOnIce: Can´t translate "dev/sda5" (wich is my swap) into a device id yet
List of all partitions:
No filesystem could mount root, tried:
Lernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(8,4)"

I hope someone can fix this! :-)

Edited 3 time(s). Last edit at 01/17/2009 04:33PM by benfm.
Re: Kernel panic stopps booting after "fine tuning"
February 12, 2009 06:28PM
I had the same problem on my MacBook, after running the 'fine-tune' the boot-process stops with a kernel panic.
I only captured a few screen-outputs of the 'fine-tune' because I was working meanwhile. Anyway, I think I have seen some output about 'lilo' and some changes to the initial ramdisk.
So maybe one solution could be to execute 'lilo' again after 'fine-tune' has finished.

Because I prefer 'grub', I solved the problem this way:

Boot the elive-CD into the console and
login as root then mount your installed system. My root-partition is on sda4. Normally, the drives are already mounted under /mnt, but I had to make a little change, because my /usr-partition is on sda5:
umount /mnt/sda5
mount /dev/sda5 /mnt/sda4/usr
We need a chroot-environment, so we have to switch proc and dev:
mount -t proc none /mnt/sda4/proc
mount -o bind /dev /mnt/sda4/dev
Let's do the chroot:
chroot /mnt/sda4 /bin/bash
Now let's install grub; the stage-files are not in /boot by default, so we copy them first, then start the grub-console:
cp /usr/lib/grub/i386-pc/* /boot/grub/
On the grub-command line you have to define your root-device, for me it is sda4:
root (hd0,3)
Install grub. I use the refit as boot-loader on the Mac, and don't want to change that, so I installed grub to be chain-loaded by it:
setup (hd0,3)
Now we have to enter the system in the boot-menu, open it with an editor:
vi /boot/grub/menu.lst
And enter something like this, depending on your kernel and initial ramdisk and your root-partition:
   default 0
   timeout 5
   title ELIVE
     root (hd0,3)
     kernel (hd0,3)/boot/vmlinuz- root=/dev/sda4
     initrd (hd0,3)/boot/initrd.img-2-.6.26.8-elive-686
Save and reboot, everything should work now.
Re: Kernel panic stopps booting after "fine tuning"
August 04, 2009 08:28PM
Interesting - this post should be made part of a faq somewhere.

ELive 1.9.16
Re: Kernel panic stopps booting after "fine tuning"
August 07, 2009 09:26PM
I agree. Roko79, can you post this in the "Misc Howtos" subforum ? Thanks