Welcome! Log In Create A New Profile

Advanced

Icedove

Posted by ibux 
Icedove
December 19, 2010 12:26PM
I would gladly appreciate an upgrade for icedove to version 3.0 or higher because so much add-ons don't work with 2.0
Thanks a lot.
Sorry, only registered users may post in this forum.

Click here to login