Welcome! Log In Create A New Profile
We moved to this Improved Forum!

Do not use this old forum, we MOVED to here!


Elive 1.9.43 (Dev) and Intel Wifi 5100

Posted by nene 
This forum is currently read only. You can not log in or make any changes. This is a temporary situation.
Elive 1.9.43 (Dev) and Intel Wifi 5100
September 15, 2009 08:55AM

Thanks in advance for any assistance.

I need help getting my Intel Wifi 5100 card working on my Elive installation.
I recently removed an installation of Fedora 11 64-bit from my Vaio VGN-Z570N because I was getting frustrated with the fact that sound would go good or bad with every single update of the installation. I use Audacity quite a bit, and sound had to be reliable.

I have Elive 1.9.34 (I think) on my home laptop, a Vaio VGN-TX770P, and been extremely happy with it. So I decided this past weekend to just trash the Fedora 11 installation on the Z-laptop for a brand new install of Elive 1.9.43. So far extremely happy except for the wireless issue.

During the installation it told me I had to rely on 'ndiswrapper' because there was no driver in Elive to support my wireless card, which is an Intel Wifi 5100.

I've done all the research I could possible try, and still can't get it to work. Please keep in mind that I'm not the most advanced Linux user, but decent enough to follow some instructions, and go from there.

I found the following post on another Elive newsgroup but it was not that helpful:

I've found plenty install information on using 'ndiswrapper', but have had issues finding the '.inf' file for my wireless card.

More confusing is that Intel Linux Wireless site offers information that my card is supported in kernel 2.6.26 and higher:

I can't get ndiswrapper to work, and I can't seem to find good details on how to make the card work with a newer Elive kernel. On top of that, each time I start Elive, I have to go to the Internet Configurator and connect manually my wired connection, even though it states that it should 'auto connect'.

If anyone with some expertise can point me in the right direction, I'll be immensely appreciative of your assistance.

Thank you.

Other notes:
0. the wifi button on the laptop is "on", and the LED shows that it is on; to cover all the bases

1. contents of /lib/firmware show the following drive available

2. ifconfig -a
eth0 ...
lo ...

3. iwconfig (no mention of wlan0)
lo no wireless extensions
eth0 no wireless extensions

4. lsmod output does not appear to show iwlagn loaded

5. "rmmod iwlagn" command tells me that 'iwlagn' does not exist in /proc/modules

6. Compilation of "compat-wireless-2009-09-14" fails
implicit declaration of function 'request_threaded_irq

7. modprobe iwl[tab][tab] shows:
iwl3945 iwl4965 iwlcore

8. I did do an 'apt-get build-essential' to try to build 'ndiswrapper' and 'compat-wireless'; both fail during compilation

9. I will continue to work for at least another couple of days, but can't be without wireless on this laptop to work in the office... might have to just simply go back and miss this great Distro;

Edited 1 time(s). Last edit at 09/15/2009 11:30AM by nene.
Re: Elive 1.9.43 (Dev) and Intel Wifi 5100
September 15, 2009 09:37PM

I had the same problem, but it should work out of the box with the kernel. You don't have to install exalt and wircd as I did when I first tried to update to the new kernel.
One thing I did when I installed the 1.9.40 and now 1.9.42 compiz version was to only allow the fine tuning application to run after I had installed the newer kernel and startup manager. Basically my steps were as follows:

1 install elive
2 ignore the request to fine tune the system
3 log into the new installed elive as root and use synaptic to install everything related to kernel and also install startup manager
4 run startup manager and select the new kernel as the default kernel to boot
5 restart the system and now allow elive to fine tune its install.

This has worked for me. The internet config only need to be set once for your wireless network now.
Also note that if you have your wired network cable pluged in, your wireless will not start automatically. I think its been programmed this way to save power or something and I guess it makes sense.
To have wireless at every boot you only need to unplug the wired cable, connect using wireless and it should start up at boot time.

One word of warning, if you use virtual machine software like VMWare, you'll need to recompile your VMWare kernel for it to work however you'll need to apply a patch found @


to get VMware to compile the kernels. This is a VMWare problem not elive. Although, it would be nice for the guys to use the newer linux kernels by default and not 2.6.24 or at least give a choice of which one to install as the systems base kernel.
Re: Elive 1.9.43 (Dev) and Intel Wifi 5100
September 16, 2009 04:02AM
Thank you so much 'leanmoha'. That was genius.

I was missing the key step of installing startup manager, and setting the kernel to 2.6.30.
Thank you for the extremely easy to follow instruction set. All is working.