Welcome! Log In Create A New Profile
We moved to this Improved Forum!







Do not use this old forum, we MOVED to here!

Advanced

Install VirtualBox and Vmware

Posted by jmnavarre 
This forum is currently read only. You can not log in or make any changes. This is a temporary situation.
Install VirtualBox and Vmware
March 08, 2008 12:24AM
El problema principal que enfrentas, después de instalar VirtualBox o Vmware es compilar el Kernel. Primero, porque cuando instalas los headers, no existe un link automatico creado en /lib/modules/2.6.18-elive, por lo tanto tienes que hacer lo siguiente antes:

#cd /lib/modules/2.6.18-elive
#ln -s /usr/src/linux-headers-2.6.18-elive build

Despues de eso, el camino se viene fácil (fácil no fue encontrar la respuesta, estaba en un forum en alemán (www.linuxforen.de/forums/showthread.php?t=229829), gracias a los alemanes por esa valiosa contribución)

Bueno, sigamos, entonces haces lo siguiente:

#cat /proc/version

para ver cuál es la version del gcc que está asociado a tu kernel, descubrirás que es 3.4.6

#dpkg -l|grep gcc

Aqui veras los gcc que tienes instalados. Si no está el gcc-3.4.6 tienes que instalarlo.

#ls -ls /usr/bin/gcc
Aqui veras la vinculacion al kernel, en mi caso era gcc-4.1

Por lo tanto, ahora tienes que hacer la vinculación correcta:

#ls -sf /usr/bin/gcc-3.4.6 /usr/bin/gcc

Con todos estos pasos, resuelves el problema de que modprobe vboxdrv no pueda insertar el modulo en el kernel.

Acto seguido, ejecutas:

#/etc/init.d/vboxdrv setup (en el caso de estar instalando VirtualBox) y,

#vmware-config.pl (en el caso de estar instalando vmware)

Bueno, hasta aquí mi humilde aporte, el cual es sólo resultado de una buena pesquisa. El merito es todo de los alemanes. :-)
Re: Install VirtualBox and Vmware
March 17, 2008 07:23AM
Oi companheiro , um error pequeno !
nao é " ls -ls /usr/bin/ ....." mas
"ln -ls /usr/bin/ .....".alem de tudo , obrigado , nao tinha conseguido a installacao do VirtualBox , sem a sua ajuda.
Re: Install VirtualBox and Vmware
April 09, 2008 03:41AM
Caro Olivier,

Você está certo, eu escrevi errado o comando de vinculação correta do gcc, o comando certo é:

ln -sf /usr/bin/gcc-3.4 /usr/bin/gcc

Uma última coisa, no caso de experimentar problemas durante a configuração do VMware com o cc1plus, teverá instalar o gcc++, no caso do exemplo acima colocado, deverá instalar o g++3.4

Um grande abraço e fico feliz de haver contribuído de alguma maneira.
Re: Install VirtualBox and Vmware
May 08, 2008 08:01PM
First: Sorry for my bad english!

I'v installed VirtualBox 1.5.6 on Ubuntu 7.10 via synaptic. It works! No problems.

Now I tried to install VirtualBox 1.5.8 on Elive GEM 1.0. I downloaded VirtualBox 1.5.8 from virtualbox.org. Then I installed via synaptic libxerces27, libicu36 and libxalan110.

Then I tried to install VirtualBox 1.5.8:
./VirtualBox-1.5.8-Linux_x86.run install

I'v got the message:
Please install the build and header files for your current Linux kernel. The current kernel version is 2.6.18-elive.

Via synaptic I installed:
linux-headers-2.6.18-6 and linux-headers-2.6.18-6-486

The problem is the same as before.
I downloaded VirtualBox 1.6.0 and tried to install it. The problem is the same as before.
I don't know what are the build files I need.
Can anybody help?
Thanks