Welcome! Log In Create A New Profile

Advanced

Alsamixer Error

Posted by LoL 
LoL
Alsamixer Error
November 16, 2008 05:51AM
I installed Frozen Bubble from the bonus disk

It worked fine, but it was a little quiet

So, I opened Alsamixer and upped the volume

I was only getting output from one speaker though, no matter which slider I adjusted

Since my PC outputs to a mixer and then a preamp, I thought I'd test the connections

It made no difference, what I did

So, I tried an audio CD through my decks instead

It definitely wasn't the connections from the master out on the mixer to the preamp, or the preamp to the speakers, because audio from the decks was fine

Maybe it was the connection from the PC to the mixer?

So, I closed Frozen Bubble

Then I closed Alsamixer

I rebooted the PC into Windows

The audio was fine

So, I rebooted into eLive and launched Alsamixer again ...

... and got the following error:

Quote:
(gnome-alsamixer:3369): GLib-GObject-CRITICAL**g_type_instance_get_private: assertion'instance != NULL && instance->g_class != NULL' failed
(There are two instances of it in the error report window, but I've only shown it once)

I get audio ...

... (still only from one speaker, even with an audio CD - So, it's not unique to Frozen Bubble) ...

... but I can't adjust it

How can I fix

a) Alsamixer?

b) The audio output?

Cheers

EDIT

I get the same problem with the 1.9.16_unstable liveCD

But the volume control works fine

And both channels are audible

So, I guess it's an Alsamixer thing
Re: Alsamixer Error
December 21, 2008 01:46PM
In synaptic, completely remove all the alsamixer packages (that don't affect important system packages.)
Restart
Download Alsa Source.
Run Module-Assistant. Choose to configure Also Source, and when it's done, choose to install the module. Exit.
Restart
Install alsamixer
Run it in the terminal, make sure you unmute everything.

If it still doesn't work, I'm clueless.
Sorry, only registered users may post in this forum.

Click here to login