Welcome! Log In Create A New Profile
We moved to this Improved Forum!







Do not use this old forum, we MOVED to here!

Advanced

Exaile on elive

Posted by babel 
This forum is currently read only. You can not log in or make any changes. This is a temporary situation.
Exaile on elive
October 15, 2007 03:37AM
Hi all. I get this error msg when i try to run exaile (a very good audio player):

/usr/share/exaile/xl/xlmisc.py:1717: GtkWarning: gdk_drawable_set_colormap: assertion `cmap == NULL || gdk_drawable_get_depth (drawable) == cmap->visual->depth' failed
pixmap.set_colormap(colormap)
/usr/share/exaile/xl/xlmisc.py:1740: GtkWarning: Using Cairo rendering requires the drawable argument to
have a specified colormap. All windows have a colormap,
however, pixmaps only have colormap by default if they
were created with a non-NULL window argument. Otherwise
a colormap must be set on them with gdk_drawable_set_colormap
pixmap.draw_layout(gc, x, y, layout)
/usr/share/exaile/xl/xlmisc.py:1740: GtkWarning: No colormap in gc_get_background
pixmap.draw_layout(gc, x, y, layout)
/usr/share/exaile/xl/xlmisc.py:1744: GtkWarning: gdkpixbuf-drawable.c:1257: Depth of the source drawable is 24 where as the visual depth of the colormap passed is 16
0, width, height)
Traceback (most recent call last):
File "exaile.py", line 2635, in ?
main()
File "exaile.py", line 2627, in main
exaile = ExaileWindow(options, fr)
File "exaile.py", line 202, in __init__
self.setup_left()
File "exaile.py", line 1036, in setup_left
self.collection_panel = panels.CollectionPanel(self)
File "/usr/share/exaile/xl/panels.py", line 235, in __init__
self.setup_widgets()
File "/usr/share/exaile/xl/panels.py", line 257, in setup_widgets
self.create_popup()
File "/usr/share/exaile/xl/panels.py", line 352, in create_popup
icon_set = gtk.IconSet(pixbuf)
TypeError: pixbuf should be a GdkPixbuf

Im not a programer so i don't have idea of what to do. Is this error caused for the enlightenment environment? tnx all
Re: Exaile on elive
December 14, 2007 04:14AM
Developers from exaile told me that msg is due to an incompatibility of the PyGTK (GTK+ for Python) because debian is using an old version of this package. So if u upgrade this package to the last version u should have no problems
Re: Exaile on elive
December 20, 2007 08:13AM
I've just tried exaile, and although it installs, it still doesn't work!
Just sits there, not even going through the motions .. no sound .. nothing!

Has anyone else had any luck with this ? .. thanks for any help folks !
Re: Exaile on elive
December 21, 2008 06:40AM
I have exactly the same problem, although I still unresolved ... using Audacious, to achieve resolve exaile

Linux es mi copiloto