Welcome! Log In Create A New Profile

Advanced

error 17 at boot, can't mount partition.

Posted by 300Z 
error 17 at boot, can't mount partition.
December 16, 2009 07:16PM
Hi everyone.

I just finished a fresh install of Elive using the 1.9.51 build (which I used for a week some months ago as a test) and now after this install I get a error 17, cannot mount selected partition, filesystem type unknown message right after selecting which OS to boot on grub. I have Ubuntu 9.04 (using XFS FS) on the first HD and Elive on the second, this is the exact same machine as it was when I first installed Elive a couple of months ago so I know it's not a CD burn problem because it worked perfectly before, the only difference is the current file system I'm using on Ubuntu, back then I was using the standard Ext3 and now XFS.
I can boot on Ubuntu just fine but not on Elive. :(

So any ideas on what could be the problem and any suggestions on how to fix it?

I hope I provided enough information. emosmile

Thanks.

Leo



Edited 1 time(s). Last edit at 12/16/2009 07:31PM by 300Z.
Re: error 17 at boot, can't mount partition.
December 18, 2009 08:01PM
Ok so I had to reinstall Ubuntu with a Ext3 and Elive to get Elive to work... so no XFS support on Elive I guess?
Re: error 17 at boot, can't mount partition.
February 11, 2010 11:39AM
I seem to remember having a similar problem in the past.

It turned out I had to have my external USB hard-drive unplugged when installing.

Not sure why that would make a difference , but after un-plugging it , and installing again , all was well!
Re: error 17 at boot, can't mount partition.
February 12, 2010 02:02AM
GRUB doesn't work with xfs filesystem. Depand on version you are using but many errors are possible. You can install lilo as bootloader or change filesystem
Sorry, only registered users may post in this forum.

Click here to login