Welcome! Log In Create A New Profile


2.1.40 live USB with persistence??

Posted by wrayc 
2.1.40 live USB with persistence??
May 18, 2013 10:18PM
I have seen this same question on previous versions. Was wondering how to make persistent a live USB created with Unetbootin. I tried even with Topaz but never got anywhere. Hassle for me to use live usb with elive2.1.40 because I have to reinstall the b43 wifi driver each time, so persistence would be nice.

Otherwise great distro


Edited 1 time(s). Last edit at 05/18/2013 10:33PM by wrayc.
Re: 2.1.40 live USB with persistence??
July 08, 2013 06:19AM
i saw this on the HOWTO persistencehttp://www.elivecd.org/Help/Howto/boot-elive-from-usb
Re: 2.1.40 live USB with persistence??
September 29, 2014 09:30AM
yes persistence works on all beta version.
Re: 2.1.40 live USB with persistence??
September 29, 2014 09:36AM
you can use the persistence as explained in the "debian live" project, i suggest to only do persistence to the /home mountpoint, otherwise can give unexpected things in /etc, with only /home should be a pretty stable option

by other side the most wanted thing for live usb's is to save networks, this actually works with the last USB images without need of persistence emosmile
Update: 2.7.2 Beta live USB with persistence + Keepassx 2.02
August 15, 2016 07:35AM
It even remembers the nvidia 340.65 install and just uses it w/o re-installing!
I used the developer's instructions of just gparted a USB after as root (sudo su):
dd if=2.7.2.beta.img of=/dev/sdb bs=4M
In gparted:
Create a 3rd primary partition of all the rest of my 8GB USB formatted as reiserfs with a label 'persistence'
mkdir /mnt/some_name
mount -L persistence /mnt/some_name
cd /mnt/some_name
echo "/ union" > persistence.conf
umount /mnt/some_name
Just remember to always hit 'Tab' on the top menu selection on booting and add
to the end of the menu line.

[Supposedly this can be permanently added by changing that line in 'syslinux.cfg' but I haven't tried that yet.]

If you have installed nvidia it will still ask again (just hit 'Enter' 3? times to the prompts) but it WILL recognize that it has already been installed.

BONUS: I compiled keepassx 2.02 [Forget about the 1.4 version that Wheezy will apt-get you. It only provides the old format that doesn't run on Android phones.] on 2.7.2. It first needed 5 more packages:
apt-get install cke qt4-qmake liblibqt4-dev gcrypt11-dev
But the
make install
set it up in the Elive menus and it WAS there still on a reboot w/ persistence!!
I'm writing this on the live distro w/ persistence right now. Keepassx dumped my form username & password right into the forum login via 'Ctrl-V' w/o a problem.

Elive is definitely my carry around distro!! In fact I just made another donation to help keep Samuel in tacos.

N.B. Please note my signature refers to my home CPU. I'm doing this on the road with Centrino Vpro IBM Thinkpad T61 out of Cochabamba BOLIVIA.

Linux User #305687
i5 3.35gHz 8GB RAM, NVIDIA GT218 [GeForce 210], 3 HDs (40 distros) - BlueStar (Arch), Calculate (Gentoo), Makulu (Ubuntu), Elive Beta 2.6.12.
Bradenton, FL EE.UU.
Sorry, only registered users may post in this forum.

Click here to login