Welcome! Log In Create A New Profile

Advanced

Compilar kernel 3.1 en elive 2.0

Posted by lobisome 
Compilar kernel 3.1 en elive 2.0
December 09, 2011 08:00AM
hola a todos
tegno instalada elive 2.0 en mi ordenador y la verdad que estoy encantado. Tengo todo lo que quiero/necesito y mas y como quien dice "out of the box". El unico problema que me he encontrado hasta ahora es que por investigar un poco descargue las fuentes del kernel 3.1.4 e intente compilarlo a la "debian way", pero al ejecutar make-kpkg --initrd kernel_image kernel_headers me da el siguiente error:

[root /usr/src/linux-3.1.4]# make-kpkg --initrd kernel_image kernel_headers
exec debian/rules DEBIAN_REVISION=3.1.4-10.00.Custom INITRD=YES kernel_image kernel_headers
/usr/bin/make -f ./debian/rules debian/stamp/binary/pre-linux-image-3.1.1
make[1]: se ingresa al directorio `/usr/src/linux-3.1.4'
====== making target debian/stamp/install/linux-image-3.1.4 [new prereqs: ]======
This is kernel package version 11.015.
echo "The UTS Release version in include/linux/version.h"; echo " \"\" "; echo "does not match current version:"; echo " \"3.1.4\" "; echo "Please correct this."; exit 2
The UTS Release version in include/linux/version.h
""
does not match current version:
"3.1.4"
Please correct this.
make[1]: *** [debian/stamp/install/linux-image-3.1.4] Error 2
make[1]: se sale del directorio `/usr/src/linux-3.1.4'
make: *** [kernel_image] Error 2
[root /usr/src/linux-3.1.4]#

alguien sabe a que es debido? me baje los kernel-headers para 686 de la 3.1.4 de debian sid, unpack en /usr/src/linux-headers-3.1.4 pero nada, el mismo error

¿Alguien podria ayudarme? empece en linux en el 98 y estuve años separado de este sistema y vuelvo a acercarme ahora, soy de la epoca de make bzImage y me pierdo un poco en este metodo, ¿que estoy haciendo mal?
Sorry, only registered users may post in this forum.

Click here to login