ADSL Internet in Elive 1.0
November 18, 2007 05:04PM
Yesterday I finally managed to install and run Elive Gem 1.0 as my third OS. I went through configuration and all is working fine, as far as I can tell at the moment. Now I want to have Internet connection emosmile
I have an ADSL connection which is working perfectly on Mandriva and Windows XP. In the first case the only thing I had to do was to copy two files to /lib/firmware folder and configure the connection with a handy wizard. Unfortunately (or maybe fortunately for some wink ) Elive isn't a rpm distro. It also don't have ADSL modem configuration wizard. Could anyone help me with this, as I'm making my first steps in deb-based distro :D
Thanks in advance.
Re: ADSL Internet in Elive 1.0
November 19, 2007 07:29AM
I have ADSL, hadnt made anything speciall to get online. Just check Elive panel, Admin and Systems configuration, then Network Configurations. In connections your network cable should appear as Ethernet Conn 1 or Ethernet Conn 2 (i have two net adapters) , if it is deactivated just Activate it, I use DHCP (dynamic IP), thats all (unless you are connected with USB which I dont recomend due to probable burn downs from lightstorm, etc.
Hope this helps.
Re: ADSL Internet in Elive 1.0
November 19, 2007 04:17PM
Hello alex2035!
Thanks for your reply. Unfortunately my situation is different than yours, as I'm using a Thomson SpeedTouch 330 USB modem. To connect on Mandriva I use PPPoA protocol. I also have to type my username and password and only then I'm able to get online.
I'm wondering whether there's an ADSL-manager or similar in Elive. I think it could help me a lot.
Re: ADSL Internet in Elive 1.0
November 20, 2007 07:43AM
I think there is: I have it in my menu after having typed : 17genmeu to scan the new programs installed (in a terminal)
After that , under Generated Menus find System and there you can find a ADSL/PPPoe configuration entry, hopefully this will lead you in the right direction emosmile
Re: ADSL Internet in Elive 1.0
November 20, 2007 07:44AM
sorry, it should have said: e17genmenu , this is typed in a terminal and scans all your programs and adds them to a Generated Menus new item. Good Luck
Re: ADSL Internet in Elive 1.0
November 22, 2007 04:17AM
I tried your method, but unfortunately got some errors. Couldn't copy and paste here the output from a console, because in Elive there isn't such an option! I always do this in Mandriva but console in Elive don't have cut, copy and paste options. Strange...
Re: ADSL Internet in Elive 1.0
November 22, 2007 11:55PM
mmm...install eterm and run e17genmenu from there.
Re: ADSL Internet in Elive 1.0
November 25, 2007 03:43AM
I got another problem...
When looking for a solution, I ran onto a program called Eppp 0.0.3. It may help me to connect to the net via my ST330 modem. Unfortunately I don't know from where to get dependencies needed to compile that application. According to INSTALL-file it requires:
- eet
- evas
- ecore
- efreet
- edje
- ewl
- e (enlightenment I guess)

Does anyone know from where to get Elive deb-packages of those applications/libraries?
Re: ADSL Internet in Elive 1.0
November 26, 2007 05:57AM
[] has under Applications, just added EPPP 0.0.3 with link to download and instructions to compile.
Re: ADSL Internet in Elive 1.0
November 27, 2007 09:34PM
Could anyone post here links to the applications mentioned above?
Re: ADSL Internet in Elive 1.0
December 11, 2007 04:42AM
So can anyone explain to me in few simple steps how to install Eppp 0.0.3 on EliveGem 1.0, please???

"./configure" gave me 3 missing packages:

Where to get them?

Edited 2 time(s). Last edit at 12/11/2007 10:59PM by Zibi1981.
Re: ADSL Internet in Elive 1.0
January 15, 2008 09:55PM
Still no response... Guess have to choose another distro, as Elive is completely useless for me without Internet connection :-(
Re: ADSL Internet in Elive 1.0
July 26, 2008 11:03AM
i had a similar problem y couldn't make my internet work, i used pppoeconf i configured all but still without internet so i had to install ubuntu 'cause i had non other OS in my pc