Welcome! Log In Create A New Profile

Advanced

VirtualBox guest additions

VirtualBox guest additions
April 11, 2008 04:44PM
I have Elive 1.0 installed in Virtualbox. However, the screen resolution is horrible and I am trying to install the VirtualBox Guest Additions to correct this problem. However, when I run sh ./VBoxLinuxAdditions.run from the correct directory I get the following message:

"VirtualBox 1.5.6 Guest Additions installation
Please install the build and header files for your current Linux kernel.
The current kernel version is 2.6.18-elive
Problems were found which would prevent the Guest Additions from installing.
Please correct these problems and try again."

When I load up Synaptic and try to find either the build-essential package or the kernel-headers package neither come up. When I try to 'aptitude install build essential', I get "The following two packages have been kept back:
libcairo2 linux-wlan-ng-firmware" and it says "2 not upgraded". Pretty much the same thing for linux-headers-'uname -r'. I tried rebooting and installing the Guest Additions again and I got the same thing. Any ideas?
Re: VirtualBox guest additions
April 16, 2008 06:16PM
I am also having this problem, only in my case, when i reboot the virtual machine, i get an error on boot.

Loading kernel modules...NULL fd-(different number every time) is (same funky characters every time)



Edited 2 time(s). Last edit at 04/19/2008 02:48PM by Drakamius.
Re: VirtualBox guest additions
July 16, 2008 12:18PM
This is still an issue for me. I have not been able to figure this out. Do any dev's know a solution?
Re: VirtualBox guest additions
August 13, 2008 03:35AM
install the following packages:

linux-headers-2.6.18-elive
libqt3-mt
libqt3-mt-dev
gcc-3.4


do this:

export KERN_DIR="/usr/src/linux-headers-2.6.18-elive"

cd /lib/modules/2.6.18-elive

ln -s /usr/src/linux-headers-2.6.18-elive build

ln -sf /usr/bin/gcc-3.4 /usr/bin/gcc

cd /media/hdc

sh VBoxLinuxAdditions.run


that was it
Re: VirtualBox guest additions
November 17, 2008 02:59PM
I am once again having an issue installing the latest development version (1.9.16) in Virtualbox. It will not install, the installer just hangs when "cleaning up". I tried version 1.9.15 and it installed but I can't seem to figure out why I can't install the Guest Additions. I installed all of the dependencies. Any thoughts?
Sorry, only registered users may post in this forum.

Click here to login