Welcome! Log In Create A New Profile
We moved to this Improved Forum!

Do not use this old forum, we MOVED to here!



Posted by marku 
This forum is currently read only. You can not log in or make any changes. This is a temporary situation.
November 16, 2008 08:24PM
am using 1.9 beta. is autologin available?
thanks for any help.
Re: autologin
November 29, 2008 05:01AM
my solution to get autologin is as follows:

apt-get install kdm

while kdm is being installed, you will be asked if you want to use kdm instead of entrance - opt for this. You can then edit the file /etc/kde3/kdm/kdmrc as root to enable autologin....

Upon googleing for entrance and autologin, I found several howtos, but following them "killed" my elive-install..
Re: autologin
March 26, 2009 07:09PM
First of all, I want to say that I'm pretty sure that there is a faster way of doing this, but anyway I will explain the steps I followed to be able to autologin in Elive:

1.I opened the console and wrote #scite /etc/apt/preferences

2.I created the new file and left it like this:

Package: *

Pin: release a=testing

Pin-Priority: 650

Package: *

Pin: release a=experimental

Pin-Priority: 600

Package: *

Pin: release a=unstable

Pin-Priority: 550

3.I added the repositories Unstable and Experimental of Debian (I recommend to look for the right spelling in Google)

# scite /etc/apt/sources.list

### Experimental cl ###

deb htpp://ftp.cl.debian.org/debian/experimental main

deb-src htpp://ftp.cl.debian.org/debian/experimental main

### Unstable cl ###

deb-src htpp://ftp.cl.debian.org/debian/sid main

deb htpp://ftp.cl.debian.org/debian/sid main

4.After "apt-get update", I installed kdm #aptitude install -t experimental kdm

5.I wrote # scite /etc/kde4/kdm/kdmrc

6.I modified the file including at the end of it these lines:






AutoLoginUser=”here include the name of your user without the quotation marks”


7.I wrote #scite /etc/profile

8.I modified the file just adding the line “export XAUTHORITY=/home/Youruser/.Xauthority” (without the quotations) before unmask 022

9.I wrote #scite /etc/sudoers

10.I modified the file like this

root ALL=(ALL) ALL

myuser ALL=(ALL) ALL

11.I rebooted the system and voilà, I had in my Elive the autologin feature.

I do not know if this is correct from a geek point of view because I'm not a nerd and have no idea about computers at all. But what the hell, it just works for me!

Edited 9 time(s). Last edit at 03/28/2009 09:24PM by trezel.