Welcome! Log In Create A New Profile
We moved to this Improved Forum!







Do not use this old forum, we MOVED to here!

Advanced

how installl kernel-sources?

Posted by gamio 
This forum is currently read only. You can not log in or make any changes. This is a temporary situation.
make make: *** /lib/modules/2.6.18-elive/build
July 31, 2007 04:41AM
Hi, i'm trying to intall my webcam and after the "make" command this error apperars to me:

make: *** /lib/modules/2.6.18-elive/build: No such file or directory. Stop.
make: *** [default] Error 2

I installed what I thought was necessary:


sudo apt-get install build-essential linux-headers-$(uname -r)

but the error is still there...Do I need the kernel-image? In this case I can't find the 2.6.18-elive version in the repositories...sound strange to me...any idea?

ciao
clhona
Re: make make: *** /lib/modules/2.6.18-elive/build
August 03, 2007 10:02PM
Re: make make: *** /lib/modules/2.6.18-elive/build
August 08, 2007 02:08AM
it was a link problem....

as root

cd /lib/modules/2.6.18-elive
ln -s /usr/src/linux-headers-2.6.18-elive build

strange that this isn't done directly at system installation...
ciao
Kernel Headers
August 15, 2007 11:14PM
Greatings,

When building the modules for vmware-tools (through the vmware-tools installer, v 5.5.3) I had a message that said that there was a slight difference between the headers and the actual running kernel.

I had the kernel headers (elive) installed via synaptic and had made the link for the modules like so:
cd /lib/modules/2.6.18-elive 
ln -s /usr/src/linux-headers-2.6.18-elive build

Maybe only Thanatermesis knows about this ...

Thanks,
Nesster
Re: Kernel Headers
August 20, 2007 03:37PM
I seem to be having this exact same problem... tried kernel headers... copied running config from /boot etc and still nothing.
Re: Kernel Headers
August 21, 2007 01:28AM
Please report that bug at [bugs.elivecd.org] with the title 'kernel-headers build linking' or something similar



Edited 1 time(s). Last edit at 08/21/2007 01:28AM by Thanatermesis.
how installl kernel-sources?
August 21, 2007 03:28PM
hi i install virtual box, but during the configuration process the installer tell me:

compilation of the kernel module failed
virtualbox will not start until this problem is fixed. Please consult /var/log/vbox-install.log to fin why the kernel module does not compile. Most probably the kernel sources where not found. Install them and execute /etc/init.d/vboxdrv setup
as root.
I been install the kernel-sources-2.6.18-elive from synaptic, i untar the file to /usr/src/kernel-source-2.6.18-elive and create the symbolic link to /usr/src/linux, but that is not working
vbox follow telling me can't find kernel-sources.
any body have a guide?, the symbolic link must point to other side?.

I hope you can understand me English is not my tongue mother, thanks for any help :(

p.d I'm using elive 1 emerald
Re: how installl kernel-sources?
August 21, 2007 04:42PM
I have filed a bug relating to this same issue with installing vmware... hopefully they look at it soon.
Re: make make: *** /lib/modules/2.6.18-elive/build
August 21, 2007 04:44PM
Have you re-built your kernel? Several people are having this same issue but the link does not resolve it for the default kernel.
Re: how installl kernel-sources?
December 03, 2007 01:54AM
when i try sudo apt-get install linux-headers-$(uname -r)

i get:

sudo apt-get install linux-headers-$(uname -r)
Reading package lists... Done
Building dependency tree... Done
E: Couldn't find package linux-headers-2.6.18-elive

Where did you all get this?
Re: how installl kernel-sources?
December 31, 2007 03:08PM
to those that apply, I had similar kernel problems where kernel source was not set up.

what I did was first

did the link thing by clhona & nesstercd
cd /lib/modules/2.6.18-elive
ln -s /usr/src/linux-headers-2.6.18-elive build

that kinda didnt work. I proceeded to copy the repository given by phoenix. to a directory

/home/[username]/downloads/firefox

now i navigated to that folder i downloaded it to and did what clhona did

sudo apt-get install build-essential linux-headers-$(uname -r)

no clue what that was but it installed the kernel alright. I would suggest u moving to the right folder first antmanx22.

thank you for your time and patience all, I am now installing ndiswrapper. it was a real pain before i chanced upon this thread.

-----------------------------------------------
I am a complete linux noob. Only recently been trying out 2-3 distros. Willing to learn. Just don't be an ass to me.



Edited 1 time(s). Last edit at 12/31/2007 03:10PM by kuanghau.
Re: Kernel Headers
January 01, 2008 07:00AM
Hello everybody,

Sorry for my "frenchie" english and for my poor explanations (I used Elive several days afo and not at the moment).

Thanks for the wonderful Distro Elive that I have installed for the first mother's computer.

While trying to get through wifi I encountered the same error, about "build not found" or something like that during a "make".

I had kernel-headers-etc... in Synaptic, installed and uninstalled kernel-source-etc... apart for some purpose.

Anyway I got the message about the "build not found" even with ever ln -s suggested.

I did some cleaning in /usr/lib just to have a clear thinking of the situation. So I delete the directory under /usr/lib called "kernel-source-etc" that was already empty and that was beside the similar directory "kernel-headers-etc" that is full and with the build but was "not found".

With no hope I tried a last "make" befre installing a new distro ... and it has worked !!!!! clap

My analysis "a posteriori" is that the make sought in the "source" directory by default and couldn't find anything in it because the active kernel is the "headers" one. . Without any "source", the "make" target the "headers"(I am a newbie so apologize my "elucubrations" (french but nice and tortuous word)).

Thanks for those who will do a try to confirm for the others the effectiveness of the proposal. I have no Elive in the hand at the moment to confirm.