Welcome! Log In Create A New Profile
We moved to this Improved Forum!







Do not use this old forum, we MOVED to here!

Advanced

NTFS-3G automounting problem

Posted by phoenix 
This forum is currently read only. You can not log in or make any changes. This is a temporary situation.
NTFS-3G automounting problem
August 22, 2007 12:02AM
Hi,

I have a problem with the automounter of Elive.

At the beginning, my NTFS partition on my external HD was well automounted.

But, I've compiled the 2.6.22.4 kernel, and I have boot on once, only for testing.
I did not do anything else!

But after that, when I'm came back to the Elive kernel, NTFS partitions were not automounted :( (manual mount is still work)

It would seems pmount to don't see ntfs-3g, but why ??

And why after a boot with an other kernel ?

How to solve that?

[sorry for my bad english]
Re: NTFS-3G automounting problem
August 22, 2007 07:12PM
remove any NTFS's modules support of your new kernel

Anyways, not-official kernels of Elive is not supported, the things that works on Elive needs to work with the kernel that Elive provides
Re: NTFS-3G automounting problem
August 23, 2007 05:21AM
Yes, but the problem is that, now, ntfs automounting do not work with the official Elive kernel (2.6.18) ....
Re: NTFS-3G automounting problem
August 23, 2007 08:05AM
you need to totaly remove Ntf3g and then reintall
you may have to alter the fstab back to the original and make sure you use the Elive Ntfs3g or you can restore elive with the disk if you do that after you need to go into file system look for a file called root
and open it read the read me file and reinstall all your software. and remember the golden rule back up before you play, then all you need to do copy and paste. you can also just copy with a live disc your home folder delete the new one and paste your saved one in its place reboot that works for me all my setting everything as it was.
Re: NTFS-3G automounting problem
August 23, 2007 02:51PM
I solved the problem (temporarily).

I modified $HOME/.ivman/launcher.sh :

Originally, it was
mountpoint=`( mount | grep $2 | awk '{print $3}' )`
        [[ -z $mountpoint ]] && { 
            pmount $2
            mountpoint=`( mount | grep $2 | awk '{print $3}' )`
            }
        mountpoint=`( mount | grep $2 | awk '{print $3}' )`
        [[ -z $mountpoint ]] && { 
            ntfsfix $2
            pmount $2
            mountpoint=`( mount | grep $2 | awk '{print $3}' )`
            }

I changed to :
mountpoint=`( mount | grep $2 | awk '{print $3}' )`
        [[ -z $mountpoint ]] && { 
            pmount -t ntfs-3g $2 || pmount $2
            mountpoint=`( mount | grep $2 | awk '{print $3}' )`
            }
        mountpoint=`( mount | grep $2 | awk '{print $3}' )`
        [[ -z $mountpoint ]] && { 
            ntfsfix $2
            pmount -t ntfs-3g $2 || pmount $2
            mountpoint=`( mount | grep $2 | awk '{print $3}' )`
            }

And ntfs automounting work. clap

But, if anybody have a better idea...
Re: NTFS-3G automounting problem
August 24, 2007 12:42AM
Patch commited emosmile