Welcome! Log In Create A New Profile
We moved to this Improved Forum!







Do not use this old forum, we MOVED to here!

Advanced

iBar and Panel auto-hide ... difficult

Posted by jdackle 
This forum is currently read only. You can not log in or make any changes. This is a temporary situation.
iBar and Panel auto-hide ... difficult
April 30, 2009 05:41AM
Hi everyone!

I'm ttrying Elive, latest development and I'm having some trouble setting up my destop, the way I want it.

Basically, Elive desktop JUST ROCKS! emosmile
But there is ONE (multiple thing) I want to change (there is actually another one but I think I have that one covered).

I want to have ALL my shelves and epplets AUTOMATICALLY HIDDEN.
On the other hand (and it even sounds a little silly to have to say this), when I move the mouse over the screen-edge they're attached to, I want them to slide-out ABOVE THE WINDOW(S).

I've successfuly auto-hidden both the taskbar (top-left) and clock (top-center).

However, it seems that as I try to tweak more complex epplets, such as the Panel (top-right) and the iBar bar at the bottom-center, it becomes more difficult.

So, here is the situation for:


1) The iBar - my actions and results:

Procedure A - iBar with iTask-NG:<br>
1.A.1. Right-click the iBar, choose "Configure bar";<br>
1.A.2. In the dialog that pops up, select "Auto-hide" on the right. - you can have a test at this now, it will in fact auto-hide. So far, so good...; wink<br>
1.A.3. In the same dialog, under "Stacking", choose "Bellow Fullscreen" or "Above All";<br>
1.A.4. Click "Apply" or "OK".<br>
Results: There is this about 1/3 of the screen-height that just turns solid-black - you can seen nothing that's supposed to be there... wow

Procedure B - iBar with a Shelf:<br>
1.B.1. Remove the iBar from iTask:<br>
1.B.1.1. Right-click the iBar, choose "Configure bar";<br>
1.B.1.2. Under "Bar Items", select "Lanucher" and click "Delete" - apply your settings: the bar is gone.<br>
1.B.2. Left-click your desktop root-window for the Main Menu and navigate Settings -> Shelfs;<br>
1.B.3. (Note: If you haven't been messing around with your shelves, you should have Shelf 1 at the bottom of your screen, you can move on to point 1.B.4) Click "Add", a new shelf appears;<br>
1.B.4. Select your shelf and click "Setup";<br>
1.B.5. In the dialog that pops up, make sure, on the "Scheme" section, the shelf location is set to where you want it and won't disturb other epplets;<br>
1.B.6. On the "Stacking" section, just above the "Schemes" one, choose "Above anything";<br>
1.B.7. On the left, mark "Auto-hide the shelf";<br>
1.B.8. Click on the "Set contents" button;<br>
1.B.9. In the new dialog, add the iBar gadget and close;<br>
1.B.10. Apply your settings.<br>
Results: The iBar is now properly auto-hidden and auto-reshown WITHOUT ANY PARTIAL SCREEN-BLANKING or anything! Great! emosmile Only... now when hovering menu ICONS BEHAVE DIFFERENTLY! Instead of the nice magnify-effect you previously had, you have this NNOYING GLITTER like the one in the taskbar (ok, that's a matter of choice, only it IS NOT: you CANNOT SET THE DEFAULT ICON BEHAVIOUR BACK ON! wow


2) The Panel suffers of the same kind of problems - you get the auto-hide/reshow behaviour I wnat through the shelf BUT you get visual and behavioral changes if you do that! The Panel is actually WORSE!!! It simply stops performing its action of switching desktops!!! wow

Is there some WORKAROUND???

Or is this plain bug-report material?

idea