Welcome! Log In Create A New Profile

Advanced

apt-get install lyx FAILED...

Posted by jtwdyp 
apt-get install lyx FAILED...
November 13, 2009 12:32PM

I've just installed elive via the "stable" elive 1.0 cd I paid to download some months ago. Would have done that sooner but I needed to decide which of my installed linux to flush to make room for it on my Gateway laptop (MT6451 Notebook PC) with an AMD Turion 64x2 processor and a 120 gig HD

I'm getting errors trying to install lyx, which is a "must have" program for me. I did an "apt-get update" then I tried "apt-get install lyx" But it fails to completely install... At the moment, my sources list can be found at:

https://home.comcast.net/~jtwdyp/fileShuttle/sources.list

The output of "apt-get install lyx 2>&1 |tee lyx-out.txt" is at:

https://home.comcast.net/~jtwdyp/fileShuttle/lyx-out.txt


Is the package broken????

How can I fix this???

--
jtwdyp
J(tWdy)P
Joe(theWordy)Philbrook
Re: apt-get install lyx FAILED...
November 14, 2009 12:39AM
In debian based off distros when an installation needs extra dependencies it gives you errors usually.After each error you have to do an
apt-get install -f
,and this command might install the needed dependencies for you and continue the lyx's installation successfully.
It's not like in Ubuntu,I know. wink

Procesor Intel Ci3-2100 3.10Ghz,64bit,3MB BOX,
4GB RAM DDR3 1333mhz,
NVIDIA GeForce 210,1GB DDR3,PCI-E,
Linux user:#492560,E17-Ecomorph user.
"This is Linux land!In silent nights you can hear Windows machines rebooting!..."
[www.youtube.com] [stanca-ultimateeditionromania.blogspot.com]#
Re: apt-get install lyx FAILED...
November 14, 2009 05:58AM
Have you tried synaptic?
Re: apt-get install lyx FAILED...
November 14, 2009 12:34PM


Thank you for the hint stanca, This sounds like it's worth a shot. I might have thought of it myself except that when I did a "man apt-get" the section on -f included a sentance that I considered as a warning that I would need to know exactly what to specifiy...
Quote
man apt-get (extract from --fix-broken)
Any Package that are specified must completely correct the problem.
But the way you write it makes me think that if I don't specify what to fix, it might actualy find the real problem...
I'll have to try it.


No Mardon, I haven't tried synaptic (at least not yet) I have a strong preference foe admin tools I can still use if I break the x server And I'm under the impression that synaptic needs the gui for a point n click interface... (does it have a text-mode tool?) But if stanca's suggestion about the -f option to apt-get doesn't work, I'll give synaptic a try...

In either case, I'll post the results here...

Thanks again



--
jtwdyp
Re: apt-get install lyx FAILED...
November 14, 2009 01:34PM

The apt-get -f did need me to be specific... So I tried it with install and each of the problematic packages..... It didn't help hmmmm
So I used --purge to get rid of the apt-get dropings and tried synaptic...
Basicly it looks like synaptic is having the same problem but it describes it diferently. I think the primary problem is with tetex-bin
which fails to install because some instalation subprocess is exiting with an error status "1" And then the other 6 items cant'be configured because they depend on tetex-bin... That said, I havn't a clue how to solve this...

synaptic's error message:
E: tetex-bin: subprocess post-installation script returned error exit status 1
E: lyx-common: dependency problems - leaving unconfigured
E: lyx-qt: dependency problems - leaving unconfigured
E: lyx-xforms: dependency problems - leaving unconfigured
E: tetex-extra: dependency problems - leaving unconfigured
E: preview-latex-style: dependency problems - leaving unconfigured
E: lyx: dependency problems - leaving unconfigured


Anyone have another suggestion???

--
jtwdyp
Re: apt-get install lyx FAILED...
November 15, 2009 08:26AM
Hey jtwdyp,
I don't know why you are having a problemconfused I just installed lyx and all the dependencies 36 in all and no problems. I'm using elive 1.9.51 development. Try the Chat IRC on your desk top.wave
Re: apt-get install lyx FAILED...
November 18, 2009 08:25AM

Maybe that's the problem. By now the repositories have likely been updated to point at packages that were optimized for the more recent versions of elive. Possibly the lyx installation script is failing because it now requires something that elive 1.0 isn't compatible with????


That's the kind of thing I expect of my gentoo based Sabayon installation, Whenever I get around to updating the version, I need to make sure I grab the latest stable shortly after it's released, and quickly install everything I expect to need. Because since I don't live for a continuous upgrade process, it won't be long before the portage tree will point at packages with dependency issues with my quickly outdated copy that I lack the skill to resolve...


I didn't expect that with apt get though. But then my other debian installation is kubuntu, where it sometimes even works to edit the sources list and run "apt-get dist-upgrade." But looking at elive's sources list, it doesn't look like there's a separate repository for each reasonably current release...

So as much as I despise the (for me days long) process of customizing any new install to one I can work with, I may have to consider upgrading to 1.9.51 development.

Then ditching the gui login in favor of startx again, making massive changes to the initial tmpuser's environment (especially the keybindings {None of which match any of the defaults}) installing and configuring user prefs on several key packages. Then I can copy the tmpuser's home dir into skel, (grep for any references to tmpuser, which must be deleted before I can begin creating my user account(s) Then I can set up my primary user account to "own" my personal data partitions... (the list of things I need to change after a new install just goes on and on.)


But I need lyx, so I guess that when I can afford to spend the time again, I'm gonna have to... <sigh>

Oh yeah, I'm not likely to try the irc thing. The closest thing to that I've ever been able to stand using is email. But I'm guessing that you must be referring to one of those meaningless icons on the bottom edge of the desktop? I say meaningless because I'd need labels to know what they are for. (I don't think I think in pictures) I don't suppose there's any way to get elive to label them?


--
jtwdyp
Sorry, only registered users may post in this forum.

Click here to login