Welcome! Log In Create A New Profile
We moved to this Improved Forum!

Do not use this old forum, we MOVED to here!


Tapping the top of the application window

Posted by ndegekubwa 
This forum is currently read only. You can not log in or make any changes. This is a temporary situation.
Tapping the top of the application window
March 19, 2010 11:48AM
On earlier versions of Elive, when I tapped three times on the top bar of a browser window or other application window, the bar would remain but the display window would collapse into the top bar. The only thing remaining on the desktop would be the bar. When I tapped on that bar three times more, the window would display again.

In my present Elive version, this function isn't working, so I am asking how does one turn this feature back on? I found it to be a very useful feature.
Re: Tapping the top of the application window
March 21, 2010 03:28AM
It is working in Elive 2.0. But it need only 2 clicks emosmile or mouse wheel.

Asus EeePC 1000H [Elive 2.0 Topaz]
Toshiba Satellite p10-802 -ATI video, ATI chipset, RealTech audio- [Elive 2.0 Topaz]
I hate ATI... but I love Elive. It work with ATI with no problem.
Re: Tapping the top of the application window
March 24, 2010 12:03AM
I decided to install the current stable Topaz version, doing a fresh install instead of upgrading the development version that I had been running. The tapping feature worked in live mode, but it doesn't work on the fresh install.

I have been prompted to do the fine tuning via a graphics box, so I input my admin password, and click. The dialogue box goes away, but then nothing happens. Is there a way to start the fine tune from command line? I want to eliminate the fine tune as the reason for the tapping feature not being available because a fine tune is required.
Re: Tapping the top of the application window
March 24, 2010 01:46AM
The fine-tuning module is called


you could try running this in command line
Re: Tapping the top of the application window
March 24, 2010 08:17AM
thanks for the info. I went to try the command line but after two days of trying to get the fine tuning program to come up in graphical mode, it finally took. So I didn't need to use the bash command.

The bad news is that the applications still won't collapse when I tap on the window top bar, after fine tuning. Anyone have any ideas?
Re: Tapping the top of the application window
March 24, 2010 10:38PM
sorry have no clue why its not working. can only say try different themes, border settings and window settings
Re: Tapping the top of the application window
August 19, 2010 04:42PM
I found out how to get the tapping at the top of the window to work. Left click on the desktop, and when the dropdown list opens up, look for the "Windows" line. On the list that opens to the right, find "Tapping the top of the window - Iceweasel" Check the box on that line, and the tapping feature will work.

I had to recently (today) reinstall Elive because it quit working on this computer. The fine tuning feature still isn't working correctly, and I tried to run it from command line both as user and root by typing slamr. The response was "command not recognized." Anyone have any ideas how to get this to work?
Re: Tapping the top of the application window
August 19, 2010 09:02PM
Dronan's reply from March still applies.

Double click or mouse wheel (do you have one? You haven't told us this in any of the posts) or even CTL-ALT-R, afaik out of the box, will all 'shade' your window in the manner you describe. And what theme are you using, as some recent themes have a 'Resize' mode when you click and drag the top half of the bar. It may be sensitive to which part of the title bar you're clicking on now.

Try also a mouse bind, in Settings panel > Input > Mouse and bind it to Window State, toggle shade. Stay with up or down for the moment (left and right will work iirc if there is at least a pixel-wide border on the window). But 3 clicks? Should bring me a drink, imo. But seriously, I have ecomoprh running on a 1x4 layout, and using Lucax3 theme, and either the scrollwheel or double-tap does shade the window for me. See if you get the same result, before customizing it to 3 clicks.
Re: Tapping the top of the application window
August 20, 2010 12:10AM
I found that the drop down list with the box to check for "window tapping" only appears when iceweasel is actually open on the desktop. If it isn't open, the item doesn't appear in the drop down list.

slamr command still doesn't work, so I can't fine tune the installation from either the command line or from the gui. Neither works. Please comment on how to fix this, that is more helpful to me than the number of clicks. I consider the window tapping problem resolved.

The operating system is hanging up on boot just before the login screen appears. The progress bar stalls almost all the way to completion on the splash screen, and I never get to the login screen. This is why I reinstalled the operating system to begin with. I have to go into reparation mode to get to command line login, and then startx to get the desktop up and running. Please comment on how this might be fixed.

These problems didn't occur in the development version, they have only cropped up since I installed the topaz stable version.
Re: Tapping the top of the application window
August 20, 2010 06:36PM
What is slamr? The google hits turn up something that appears obsolete. What happens when you run other live CDs, do they also hang or hesitate before displaying the GUI?

Where did you put slamr? Run an 'echo $PATH' (without quotes) to see where you should put executables; i.e. I put my downloaded or new executable programs in /usr/local/bin, since that location is part of the $PATH.

Please describe or list your hardware, if you consider the other issue resolved at this point.

When you boot elive, enter the option splash=verbose*, so you can tell what message is shown when it hangs. Do you run X with ecomorph already on? These things will clue others in as well.

*Unless it already displays those messages, but let us know what the last one is.
Re: Tapping the top of the application window
August 22, 2010 06:24AM
I will try to answer your questions.

What is slamr?
Please look in the fourth post in this thread, by leanmoha. It is purported to be the command that will run fine tuning. I ran it in terminal as root. I am not running the command before installation using a live cd, I ran it in the installed operating system booting from hard drive. I ran it as root in terminal.

What happens when I run other live cds, do they hang or hesitate?
No, they don't hang or hesitate. But then, neither does the elive live cd. The problem of the splash screen hanging occurs on the installed system booting from hard drive.

Where did I put slamr?
I didn't put it anywhere, fine tuning was supposed to be installed with the operating system. I tried to see if slamr was a program that was installable, but I don't get any results with synaptic or apt-get.

Please list my hardware.
The particular computer that I had the Topaz 2.0 installed on was a Toshiba Satellite U505-S2950. It has 320GB hard drive and 4gb ram. The processor is a dual core pentium t4300.

When I boot, enter splash=verbose. Post results here.
I will do this, but I have to reinstall the 2.0 version. I reinstalled an earlier development version, 1.9.58, because I got tired of the 2.0 version hanging up and the 1.9.58 version works. I hadn't had a reply on the forum, and had some free time to work on the computer the other day, so to get rid of the splash-screen hanging problem I reinstalled the development version. I will probably get the 2.0 version reinstalled in a couple of days. The message that was displayed on 2.0 was "entranced" when the splash screen hangs up.

Do I boot with ecomorph on?
No, I didn't have ecomorph installed yet.

I hope that these answers will aid you in helping me resolve these problems. If you need more information, please post back and I will provide you with what you need.