Welcome! Log In Create A New Profile

Advanced

Update - Elive version confusion ?

Posted by ericc 
Update - Elive version confusion ?
June 13, 2010 03:58AM
Hello

I use elive since quite some time.
As far as I know, I have installed the Gem version but I'm not 100% sure

Since the release of Topaz version, I didn't see any package upgrade with :
Quote

apt-get update && apt-get dist-upgrade
in /etc/apt/sources-list, I have only this lines :
Quote

deb [us.repository.elive-systems.com] lenny main elive drivers tests efl ports multimedia games
deb [us.debian.elive-systems.com] lenny main contrib non-free

but when I read '/etc/elive-version', I see :
Quote

elive-version: 0.3
debian-version: etch
So first confusion : in the sources list , I see 'lenny' and 'elive-version' say 'etch' !!

I downloaded the Topaz iso and booted it in VirtualBox
the 'sources-list' seems to be the same, however the 'elive-version' say :
Quote

elive-codename: Topaz
elive-version: 2.0
debian-version: lenny
date-builded: 2010-03-09
stable-release: yes

So my questions:
Is it normal that no update are available since more than 1 month ?
In which version my system is ? (my kernel seems to be the same as in Topaz !!)
Do I have something to change to be sure that my system is up to date ?

Before, I used 'Elive Revolution' when I "update" manually from the iso image, I lost nearly all my data (luckily I had a backup)
but I don't want to live the same experience again

ericc



Edited 1 time(s). Last edit at 12/23/2010 12:35PM by anu.
Re: Update
June 14, 2010 07:09AM
Hi!
cat /etc/elive-version

Will show you what version you are running.

Have Fun!

Elive für Einsteiger: [sites.google.com]
Re: Update
June 14, 2010 07:21AM
Hi Alex

Thank for your answers but I fear that you didn't read my message closely !

Every seems to indicate that my system is up to date and that I'm running the Topaz version.
However, as I said and as you suggest, my file '/etc/elive-version' is quite different than those from the liveCD of Topaz :
Quote

elive-version: 0.3
debian-version: etch

I should have :
elive-version: 2.0 !!
(well I hope, that I should have ...)


And my 2nd question (the most important for me) :
Quote
ericc
Is it normal that no update are available since more than 1 month ?

Thx
ericc
Re: Update
June 14, 2010 08:59AM
Hey Eric!

What makes you think you should have Elive Topaz?

Your elive-version is clearly indicated as 0.3.
You can also read it is based on Debian etch, which is a little old.
See this list: http://en.wikipedia.org/wiki/Debian#Release_history


Even if your Sources List shows lenny-sources it still remains Elive_0.3.

And yes, it is normal, that there are not too many NEW upgrades available for etch these Days.
Because etch is, as mentioned above, a little old.
Also latest Elive Version (Topaz) seems not to have any mentionable Upgrades these Days.


Have Fun!

Elive für Einsteiger: [sites.google.com]



Edited 1 time(s). Last edit at 06/14/2010 09:16AM by AlexAnteMachina.
Re: Update
June 14, 2010 10:36AM
Hi Alex

Well, I think that I have Topaz, because first, I didn't install Gem but a development version (elive_1.9.49_unstable)
second, as far as I can compare, I have the same kernel as Topaz : Linux Elive 2.6.30.9-elive-686 #1 SMP
When I read '/etc/debian-version' , I see 5.0.3 (Etch was 4.0 as far as I remember)

And when I compare the version of some software installed on my machine (like Apache or MySQL) with those available from [packages.debian.org] , I see that all are the same version as Lenny , Debian 5.0 stable

I don't thing that it's a big deal , but just to be sure
or may be it's a bug wink

ericc
Sorry, only registered users may post in this forum.

Click here to login