Welcome! Log In Create A New Profile
We moved to this Improved Forum!

Do not use this old forum, we MOVED to here!


Terminal configurator (Terminal manager) will not change font style

Posted by Larrydc 
This forum is currently read only. You can not log in or make any changes. This is a temporary situation.
Terminal configurator (Terminal manager) will not change font style
January 27, 2011 02:50AM
On an installed Elive 2.0, Choosing #3 Change font style only changes to some ugly mono-spaced font. No matter whether choosig Elive fonts or any other ttf font. I have to reset defaults to get back to something usable.

Is it because I mustn't use TTF fonts?

Thanks ahead of time/

Linux User #305687
i5 3.35gHz 8GB RAM, NVIDIA GT218 [GeForce 210], 3 HDs (40 distros) - Elive Beta 2.9.90
Bradenton, FL EE.UU.
Re: Terminal configurator (Terminal manager) will not change font style
January 27, 2011 11:07AM

I put my extra fonts (with .ttf in their name) in /usr/share/fonts/truetype/elivefonts/

You should be okay then...
Re: Terminal configurator (Terminal manager) will not change font style
January 28, 2011 11:38PM

I guess I wasn't clear.

I am just trying to pick another font for the terminal from those ALREADY in /usr/.../elivefonts directory :

#NAME 6 of 21
Dec 04 2006 45,060 -->> HoneyScript-Light.ttf
Dec 04 2006 50,896 -- Adventure.ttf
May 29 2007 51,984 -- daniel.ttf
Dec 04 2006 52,092 -- Note_this.ttf
Dec 04 2006 55,220 -- PROJECTS.TTF
Dec 04 2006 59,900 -- UnZialish.ttf
May 29 2007 63,688 -- danielbd.ttf
Dec 04 2006 66,332 -- 4990810_.TTF
Dec 04 2006 69,636 -- shanghai.ttf
Dec 04 2006 71,800 -- CloisterBlack.ttf
Dec 04 2006 82,072 -- SCRIPTIN.ttf
May 29 2007 88,760 -- danielbk.ttf
Dec 04 2006 89,108 -- marigoldwild.ttf
Jul 09 2003 95,576 -- PhontPhreaks_Handwriting.ttf
Dec 04 2006 98,340 -- TRIBTWO_.ttf
Apr 01 2008 130,956 -- journal.ttf
No matter which one I pick I get the SAME lousy monospaced font. My question is: HOW can I change the font. Applications->Administration->Terminal configurator does NOT work except to change the size of the font!
3. Change font style will NOT change the style, even when I choose a font ALREADY in your suggested directory .../elivefonts.
Re: Terminal configurator (Terminal manager) will not change font style
January 29, 2011 04:04AM

Right, I misunderstood, sorry about that

The same thing happens to me, and I gave up on that little tool. This is the problem: I have an .Xdefaults file and the font is specified in there. If I go 'pick a font style' the tool BLANKS OUT my default font and fails to insert the chosen font, but it leaves the other stuff intact such as URxvt.font:xft::pixelsize=16. The fontstyle should have been inserted between the two colons '::'.

So since urxvt doesn't know what to do, you get that same ugly font each time. I fixed mine this way: I made the font change in .Xdefaults permanently using vi. If you decide to do likewise, don't forget to xrdb -merge .Xdefaults
Re: Terminal configurator (Terminal manager) will not change font style
January 30, 2011 02:19AM

Thanks for the xrdb... command.

I removed my own .Xdefaults and ran Terminal Configurator again to see if it changed anything. It still would not allow any other fonts. Just the same ugly one above.

Then I just gave up and pulled my old Arch-Linux .Xdefaults (My Athlon 1700+ w/ an Chiantech GeForce 2 MX400(nvidia) video card is just too antiquated for a rolling release distro.) and used that.
! to override any if the settings below, use the file
! /etc/X11/app-defaults/URxvt-local

! now preloaded some defaults for Debian

URxvt.saveLines: 5000

URxvt*termName: rxvt
URxvt.title: URxvt Terminal

URxvt.cursorColor: #dc74d1
URxvt.pointerColor: #dc74d1
URxvt.background: #0e0e0e
URxvt.foreground: #4ad5e1
URxvt.color0: #000000
URxvt.color8: #8b8f93
URxvt.color1: #dc74d1
URxvt.color9: #dc74d1
URxvt.color2: #0eb8c7
URxvt.color10: #0eb8c7
URxvt.color3: #dfe37e
URxvt.color11: #dfe37e
URxvt.color5: #9e88f0
URxvt.color13: #9e88f0
URxvt.color6: #73f7ff
URxvt.color14: #73f7ff
URxvt.color7: #e1dddd
URxvt.color15: #e1dddd
URxvt.font: xft:Bitstream Vera Sans Mono:autohint=true:pixelsize=10
URxvt.italicFont: xft:Bitstream Vera Sans Mono:italic:autohint=true:pixelsize=10
URxvt.boldItalicFont: xft:Bitstream Vera Sans Mono:bold:italic:autohint=true:pixelsize=10

I left the first 4 lines from Elive and added the URxvt.font line 3rd from the bottom. I use vfu instead of Thunar or Dolphin so my terminal fonts are important to me.
Also I use mcedit or aee.

Thanks for your help.... Now to get brasero to burn dvds!!!!