Welcome! Log In Create A New Profile
We moved to this Improved Forum!







Do not use this old forum, we MOVED to here!

Advanced

can't MAKE kernel driver, no wifi

Posted by jonah 
This forum is currently read only. You can not log in or make any changes. This is a temporary situation.
can't MAKE kernel driver, no wifi
October 04, 2007 02:32AM
Hi I can’t use my wireless Edimax card as the shipped rt61 driver won’t work so i have to instead use this:

[rt2x00.serialmonkey.com]

BUT it won’t compile in elive. the make command doesnt work even with headers and source installed. can someone please help.

I know i need to use this driver as i’ve used it before. the MAKE worked in ubuntu and fedora and was simple to get my edimax card working.

i’ve uninstalled the rt61 generic driver from elive ready to install this specific legacy one, can someone please give advice, i’m sure it’s just cos some symlinks are wrong or something.

terminal output:

root@EliveCanvas[/home/jonah/Desktop/rt61-cvs-2007100406/Module]# make make: * /lib/modules/2.6.18-elive/build: No such file or directory. Stop. rt61.ko failed to build! make: * [module] Error 1
Re: can't MAKE kernel driver, no wifi
October 07, 2007 09:27AM
ln -s /usr/bin/gcc-3.4 /usr/bin/gcc
Re: can't MAKE kernel driver, no wifi
October 08, 2007 01:27AM
thanks for the tip but it still won't work...

the above will not work for me, here's what i get:

jonah@EliveCanvas:~$ ln -s /usr/bin/gcc-3.4 /usr/bin/gcc

jonah@EliveCanvas:~/Desktop/rt61-cvs-2007100406/Module$ make

rt61.ko failed to build!

jonah@EliveCanvas:~/Desktop/rt61-cvs-2007100406/Module$
Anonymous User
Re: can't MAKE kernel driver, no wifi
October 10, 2007 05:31AM
Here you have a guide, I hope that it should be helpful to him:

[wiki.elivecd.org]
Re: can't MAKE kernel driver, no wifi
October 11, 2007 11:12PM
apparently the kernel has some issues, there is a sticky now at the top of this forum with a fixed kernel/source and nvidia drivers...
Re: can't MAKE kernel driver, no wifi
January 01, 2008 07:37AM
Hello

I tried to install the same wifi card some days ago.

I got through the MAKE issue you are talking about and the solution I found is explained in another post that is repeated just after.


After that, I saw a new error during a modprobe "error inserting rt61" That I resolved with the good drivers I think. This post could help :

[forum.hardware.fr]


For the wifi card, I found some good debian posts :

[forum.debian-fr.org]

[forums.debian.net]

"[forum.ubuntu-fr.org];

I can't really remember which one I used but I think that I have tried the last one and that's all of them (and others in Google) show the good way.


But I encountered a new message during modprobe "invalid format" that killed my hope. I founf a post that talked about using the good gcc version during the make but I did not know the "gcc -v" command at that moment. So I changed the wifi card for an atheros one.

I think I was very near to the success but as a newbie it was too hard for me. May be someone or yourself could find the final way to help you.

________________________________________

Hello everybody,

Sorry for my "frenchie" english and for my poor explanations (I used Elive several days afo and not at the moment).

Thanks for the wonderful Distro Elive that I have installed for the first mother's computer.

While trying to get through wifi I encountered the same error, about "build not found" or something like that during a "make".

I had kernel-headers-etc... in Synaptic, installed and uninstalled kernel-source-etc... apart for some purpose.

Anyway I got the message about the "build not found" even with ever ln -s suggested.

I did some cleaning in /usr/lib just to have a clear thinking of the situation. So I delete the directory under /usr/lib called "kernel-source-etc" that was already empty and that was beside the similar directory "kernel-headers-etc" that is full and with the build but was "not found".

With no hope I tried a last "make" befre installing a new distro ... and it has worked !!!!! clap

My analysis "a posteriori" is that the make sought in the "source" directory by default and couldn't find anything in it because the active kernel is the "headers" one. . Without any "source", the "make" target the "headers"(I am a newbie so apologize my "elucubrations" (french but nice and tortuous word)).

Thanks for those who will do a try to confirm for the others the effectiveness of the proposal. I have no Elive in the hand at the moment to confirm.