Need to go 64 bits for different applications
June 30, 2018 04:59AM
From Elive 2.9.97

I tried the following

sudo apt-get install libc6-amd64 multiarch-support linux-image-3.16.0-0.bpo.4-amd64

sudo dpkg --add-architecture amd64

Rebooted ans uname report my system is i686

What else I could try to go 64 bits as some of the software I use are only 64bits

JF
Re: Need to go 64 bits for different applications
July 04, 2018 07:41PM
Using these steps, your system will STILL being 32 bits (all the software packages running on it), BUT now you should be able to run 64 bit software, this means, your system is the same elive one in 32 bits, and now you can install (or just run) 64 bit software, you can try for example installing the Virtualbox version of 64 bits for debian/wheezy which should work and run perfectly
Re: Need to go 64 bits for different applications
July 04, 2018 09:34PM
OK i understand tks !

JF
TO make my life easier, I created a WINDOWS WM for my wife, using the last version of ORacle VirtualBox (went back to ubuntu temporarily but will come back to Elive on my desktop as soon as I tested my 64bits apps and that I can install last version of vmware).
Re: Need to go 64 bits for different applications
July 04, 2018 11:37PM
Thanatermesis Wrote:
-------------------------------------------------------
> Using these steps, your system will STILL being 32
> bits (all the software packages running on it), BU
> T now you should be able to run 64 bit software, t
> his means, your system is the same elive one in 32
> bits, and now you can install (or just run) 64 bit
> software, you can try for example installing the V
> irtualbox version of 64 bits for debian/wheezy whi
> ch should work and run perfectly

1) what is the best way to install he actual VBox, I come from the Ubuntu world, don't forget... SO I open synaptic package manager and check everything that is ubuntu for complete removal and Apply

2) I tried to run 2 commands that didn't worked that I found on the web for complete removal of VirtualBox

3) downloaded the last version of Virtual Box deb files and clicked it from the file manager virtualbox-5.2_5.2.14-123301-Debian-wheezy_amd64.deb

From here what do I do ?



Edited 1 time(s). Last edit at 07/04/2018 11:50PM by jfb.
Re: Need to go 64 bits for different applications
July 05, 2018 09:25AM
1) Elive included virtualbox with their drivers, but for use the last version, you should use the one from their website, the 32 bits is fine if you dont want to use more than 4GB for the virtualized machine, for install the last version you need first a full removal of the old virtualbox:

sudo apt-get remove --purge virtualbox\*

because virtualbox has a kind of small bug, you need to remove also the installed drivers manually (and to reboot the machine after that):

sudo rm /lib/modules/**/vbox*ko

then you can install the download virtualbox package from their website (for debian/wheezy)



Edited 1 time(s). Last edit at 07/05/2018 09:26AM by Thanatermesis.
Re: Need to go 64 bits for different applications
July 07, 2018 12:09AM
Quote
Thanatermesis
3) downloaded the last version of Virtual Box deb files and clicked it from the file manager virtualbox-5.2_5.2.14-123301-Debian-wheezy_amd64.deb

- I added 64 bits support following your instraction
- removed VBox using your commands
- downloaded last version of Vbox for wheezy

When installing it tells me that libc6 is not the right version and stop at the beginning.

Should I wait you upgrade Elive to 64bits ?

No rush.... It can wait
JF
Re: Need to go 64 bits for different applications
July 09, 2018 09:25AM
That error is about the distro version, make sure that you download the version for Wheezy
Re: Need to go 64 bits for different applications
July 09, 2018 11:34AM
Thanatermesis Wrote:
-------------------------------------------------------
> That error is about the distro version, make sure
> that you download the version for Wheezy
Ok tks, I I will try again and let you know
JF
Re: Need to go 64 bits for different applications
July 09, 2018 09:44PM
Thanatermesis Wrote:
-------------------------------------------------------
> That error is about the distro version, make sure
> that you download the version for Wheezy

Here is what I did
[www.dropbox.com]

JF
Re: Need to go 64 bits for different applications
July 10, 2018 07:33PM
In the first boot (grub) you have booted in the old kernel, not the new installed one (amd64), you need to boot in amd64 kernel (minute 1:17)
Re: Need to go 64 bits for different applications
July 10, 2018 09:45PM
Thanatermesis Wrote:
-------------------------------------------------------
> In the first boot (grub) you have booted in the ol
> d kernel, not the new installed one (amd64), you n
> eed to boot in amd64 kernel (minute 1:17)

Same on me...
Ok will try tks !

BTW I am watching a lot of linux video on Youtube to "catch up " on my lack of linux / Debian knowledges.
Re: Need to go 64 bits for different applications
July 10, 2018 09:56PM
OK I booted with the new kernel

uname
report Linux ELive-VM 3.16.0.0.bpo.4-amd64 #1 Debian 3.16.7

Still receiving the error :
Dependency is not satisfiable: libc6 (>=2.7) when trying to install vbox 64 bits
Re: Need to go 64 bits for different applications
July 11, 2018 03:30AM
> Still receiving the error :

Sounds like we will better wait for the next beta's after 3.0

> BTW I am watching a lot of linux video on Youtube to "catch up " on my lack of linux / Debian knowledges.

Don't miss these ones emosmile : [main.elivecd.org]
Re: Need to go 64 bits for different applications
July 11, 2018 03:44AM
Thanatermesis Wrote:
-------------------------------------------------------

> Don't miss these ones emosmile : [main.elivecd.org]
> /ss/display.php?image=e-5b464c8b97f973.85597291.jp
> g


Tks !!! will read them for sure !
JF
Sorry, only registered users may post in this forum.

Click here to login