Welcome! Log In Create A New Profile

Advanced

Refrsh munu after instalation of new apps

Posted by brofio 
Refrsh munu after instalation of new apps
December 05, 2007 11:21AM
Hi, I'm writing from Italy emosmile
I've got a problem with Elive and E17:
after installation/disinstallation of programs, the mneu doesn't refrsh, so I can't see new application and can lauch them only with executeprog.
How can I solve this problem?

I've got the unstable, but the problem existed in the v.1 stable too.
Thank you guys!
Re: Refrsh munu after instalation of new apps
December 05, 2007 12:27PM
Totally agree. Im using dev too but i used gem and the problem persist.
In fact there's another problem in dev. In the menu u can see software u haven't installed!!! i think that's a problem too, not too annoying but still a problem
Re: Refrsh munu after instalation of new apps
December 05, 2007 03:18PM
yes, the problem about menu can be divided into:

1) not showing new applications
2) doesn't cancel removed applications
3) sometimes shows uninstalled applications

somebody agrees?
Re: Refrsh munu after instalation of new apps
December 05, 2007 03:35PM
i do. developers gotta do something
Re: Refrsh munu after instalation of new apps
December 06, 2007 03:19AM
ok, now I'm writing to the guys of Enlightenment to let them know this thing and maybe we can find a fast solution.. or attend a new release emosmile
Re: Refrsh munu after instalation of new apps
December 06, 2007 11:50PM
Hi... don't know if you have seen that, but after softs are installed, you have to run
e17genmenu
and it will be ok.
flirty

Ubuntu is a very old african word, to say :
"I can't understand my Debian..."



Edited 1 time(s). Last edit at 12/06/2007 11:51PM by monfraide.
Re: Refrsh munu after instalation of new apps
December 07, 2007 02:39AM
hi monfraide, the command must be run from terminal?
o I need to install some extra software?
Because I don't have it (it told me unknown command..)

Edit:

I found the package here: [sourceforge.net]
and after downloading, I converted into a .deb with Alien.
I tried to install it, but it generates conflicts with eutils.
I uninstalled eutils (and elpanel and engage-manager) so could install e17genmenu.
But,once I run it, it tells me:
couldn't find libecore....so doesn't work.

I put off genmenu e installed again eutils & elpanel & engage-manager.

Any way to solve this mismatch?



Edited 1 time(s). Last edit at 12/07/2007 03:14AM by brofio.
Re: Refrsh munu after instalation of new apps
December 17, 2007 04:23AM
actually, I didn't have to download anything I just typed in e17genmenu into the terminal and it took off and then aborted at the end with this message *** glibc detected *** free(): invalid pointer: 0x0829ead5 ***
Sorry, only registered users may post in this forum.

Click here to login